Skip to content

Commit b134dd4

Browse files
authored
gcom4: pickup the oneapi specific config file (#208)
1 parent c97ce7c commit b134dd4

File tree

1 file changed

+4
-0
lines changed

1 file changed

+4
-0
lines changed

packages/gcom4/package.py

+4
Original file line numberDiff line numberDiff line change
@@ -34,6 +34,8 @@ def gcom_machine(self, spec):
3434
"""
3535
if spec.satisfies("%intel"):
3636
mach_c = "ifort"
37+
elif spec.satisfies("%oneapi"):
38+
mach_c = "oneapi"
3739
elif spec.satisfies("%gcc"):
3840
mach_c = "gfortran"
3941
else:
@@ -55,6 +57,8 @@ def patch(self):
5557
filter_file(
5658
r"build\.target\{ns\}.*", "#",
5759
join_path("fcm-make", "gcom.cfg"))
60+
# MS: The oneAPI config already uses the `-qopenmp` flag, so a
61+
# substitution is not required for oneAPI.
5862
if self.spec.satisfies("%intel"):
5963
machine = self.gcom_machine(self.spec)
6064
filter_file(

0 commit comments

Comments
 (0)