Skip to content

Commit 7645ef6

Browse files
committed
community-patches: dxvk: Update rainbow HUD for D9VK merge
1 parent 4550240 commit 7645ef6

File tree

1 file changed

+5
-5
lines changed

1 file changed

+5
-5
lines changed

Diff for: community-patches/dxvk/rainbow_hud.dxvkpatch

+5-5
Original file line numberDiff line numberDiff line change
@@ -114,11 +114,11 @@ index 8b658c49d..ce88bfb16 100644
114114
void drawText(
115115
float size,
116116
@@ -129,6 +133,8 @@ namespace dxvk::hud {
117-
118-
Rc<DxvkBuffer> m_vertexBuffer;
119-
VkDeviceSize m_vertexOffset = 0;
117+
uint32_t m_currTextVertex = 0;
118+
uint32_t m_currTextInstance = 0;
119+
uint32_t m_currLineVertex = 0;
120120
+
121121
+ dxvk::high_resolution_clock::time_point m_startTime;
122+
123+
void allocVertexBufferSlice();
122124

123-
DxvkBufferSlice allocVertexBuffer(
124-
VkDeviceSize dataSize);

0 commit comments

Comments
 (0)