Skip to content

Commit 1d34cc8

Browse files
committed
meta-aws-demos: add more known good tests
1 parent a8ca9be commit 1d34cc8

File tree

2 files changed

+6
-3
lines changed

2 files changed

+6
-3
lines changed

README.md

+1-1
Original file line numberDiff line numberDiff line change
@@ -60,7 +60,7 @@ buildbot checkconfig configuration/admin/admin.cfg
6060

6161
deploy new config:
6262
```bash
63-
npm run zip-config && cdk deploy --force BuildBotConfig-Personal
63+
npm run zip-config && cdk deploy --force BuildBotConfig-Personal --require-approval never
6464
```
6565

6666
debug ecs container:

configuration/admin/admin.cfg

+5-2
Original file line numberDiff line numberDiff line change
@@ -448,7 +448,7 @@ for branch in meta_aws_demos_supported_branches:
448448
set -euxo pipefail;
449449
echo 'ACCEPT_FSL_EULA = \"1\"' >> conf/local.conf ;
450450
echo 'BB_DANGLINGAPPENDS_WARNONLY = \"1\"' >> conf/local.conf ;
451-
for i in \"qemu-arm64 aws-greengrass-test-image\" \"rpi4-64 aws-greengrass-test-image\" \"rpi4-32 aws-greengrass-test-image\" \"ec2-arm64 aws-greengrass-test-image\" \"ec2-x86-64 aws-greengrass-test-image\";
451+
for i in \"agl-renesas aws-greengrass-test-image\" \"agl-rpi aws-greengrass-test-image\" \"imx8m aws-greengrass-test-image\" \"phytec aws-greengrass-test-image\" \"qemu-arm64 aws-greengrass-test-image\" \"qemu-x86-64 aws-greengrass-test-image\" \"rpi4-64 aws-greengrass-test-image\" \"rpi4-32 aws-greengrass-test-image\" \"ec2-arm64 aws-greengrass-test-image\" \"ec2-x86-64 aws-greengrass-test-image\" \"ti-am572x-idk aws-greengrass-test-image\";
452452
do set -- $i # Convert the "tuple" into the param args $1 $2... ;
453453
echo DEVICE: $1 and IMAGE: $2;
454454
BB_ENV_PASSTHROUGH_ADDITIONS="SSTATE_DIR $BB_ENV_PASSTHROUGH_ADDITIONS" SSTATE_DIR="/sstate" DEVICE=$1 IMAGE=$2 bitbake $2 -k;
@@ -467,20 +467,23 @@ for branch in meta_aws_demos_supported_branches:
467467
done
468468
'''],
469469
name="build images combinations",
470+
flunkOnFailure=False,
470471
description="IMAGE + DEVICE combinations"))
471472

472473

473474
meta_aws_release_factory.addStep(steps.ShellCommand(
474475
command=['/bin/bash', '-c', '''. init-build-env;
475476
set -euxo pipefail;
476-
META_AWS_PACKAGES=$(find ../layers/sw/meta-aws -name *.bb -type f | sed 's!.*/!!' | sed 's!.bb!!' | sed 's!_.*!!' | sort | uniq | sed -z $'s/\\\n/ /g') &&
477+
THINGS_TO_EXCLUDE="-name neo-ai-tv*" &&
478+
META_AWS_PACKAGES=$(find ../layers/sw/meta-aws -name *.bb -type f ! \( ${THINGS_TO_EXCLUDE} \) | sed 's!.*/!!' | sed 's!.bb!!' | sed 's!_.*!!' | sort | uniq | sed -z $'s/\\\n/ /g') &&
477479
for d in $(get_devices);
478480
do for i in $(get_images);
479481
do BB_ENV_PASSTHROUGH_ADDITIONS="SSTATE_DIR $BB_ENV_PASSTHROUGH_ADDITIONS" SSTATE_DIR="/sstate" DEVICE=$d bitbake ${META_AWS_PACKAGES} -k;
480482
done;
481483
done
482484
'''],
483485
name="build all meta-aws packages",
486+
flunkOnFailure=False,
484487
description="build all meta-aws packages for all DEVICEs"))
485488

486489
workername = "meta_aws_demos_release_worker_"+branch

0 commit comments

Comments
 (0)