Skip to content

Commit 2124d92

Browse files
committed
pypi-jsonschema: Autospec creation for update from version 4.15.0 to version 4.16.0
Julian Berman (7): Enable OpenGraph and copy buttons for the docs. Squashed 'json/' changes from 4cfead7ba..6eaf7dff4 Remove some now-unnecessary path mangling in doc builds. Squashed 'json/' changes from 6eaf7dff4..ed0b855e7 Fix more $ref cases when the lookup URL is different from an $id v4.16.0 -> CHANGELOG Deprecate jsonschema.draftN_format_checker attributes.
1 parent d412916 commit 2124d92

File tree

7 files changed

+20
-18
lines changed

7 files changed

+20
-18
lines changed

Makefile

Lines changed: 1 addition & 1 deletion
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-jsonschema
2-
URL = https://files.pythonhosted.org/packages/7c/0d/d19c78ccd17814818497fb4be515638fd707afd98d7dc102f0ad7297e0da/jsonschema-4.15.0.tar.gz
2+
URL = https://files.pythonhosted.org/packages/cf/54/8923ba38b5145f2359d57e5516715392491d674c83f446cd4cd133eeb4d6/jsonschema-4.16.0.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

buildreq_cache

Lines changed: 1 addition & 1 deletion
Original file line numberDiff line numberDiff line change
@@ -1,2 +1,2 @@
1-
4.15.0
1+
4.16.0
22
pypi-pytest

options.conf

Lines changed: 3 additions & 1 deletion
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-jsonschema
3-
url = https://files.pythonhosted.org/packages/7c/0d/d19c78ccd17814818497fb4be515638fd707afd98d7dc102f0ad7297e0da/jsonschema-4.15.0.tar.gz
3+
url = https://files.pythonhosted.org/packages/cf/54/8923ba38b5145f2359d57e5516715392491d674c83f446cd4cd133eeb4d6/jsonschema-4.16.0.tar.gz
44
archives =
55
giturl = https://github.com/Julian/jsonschema/
66
domain =
@@ -35,6 +35,8 @@ insecure_build = false
3535
keepstatic = false
3636
# do not require autostart subpackage
3737
no_autostart = false
38+
# do not use the replacement pattern for file matching
39+
no_glob = false
3840
# do not generate debuginfo for this package
3941
nodebug = false
4042
# disable stripping binaries

pypi-jsonschema.spec

Lines changed: 12 additions & 12 deletions
Original file line numberDiff line numberDiff line change
@@ -3,10 +3,10 @@
33
# Generated by: autospec.py
44
#
55
Name : pypi-jsonschema
6-
Version : 4.15.0
7-
Release : 90
8-
URL : https://files.pythonhosted.org/packages/7c/0d/d19c78ccd17814818497fb4be515638fd707afd98d7dc102f0ad7297e0da/jsonschema-4.15.0.tar.gz
9-
Source0 : https://files.pythonhosted.org/packages/7c/0d/d19c78ccd17814818497fb4be515638fd707afd98d7dc102f0ad7297e0da/jsonschema-4.15.0.tar.gz
6+
Version : 4.16.0
7+
Release : 91
8+
URL : https://files.pythonhosted.org/packages/cf/54/8923ba38b5145f2359d57e5516715392491d674c83f446cd4cd133eeb4d6/jsonschema-4.16.0.tar.gz
9+
Source0 : https://files.pythonhosted.org/packages/cf/54/8923ba38b5145f2359d57e5516715392491d674c83f446cd4cd133eeb4d6/jsonschema-4.16.0.tar.gz
1010
Summary : An implementation of JSON Schema validation for Python
1111
Group : Development/Tools
1212
License : MIT
@@ -66,18 +66,18 @@ python3 components for the pypi-jsonschema package.
6666

6767

6868
%prep
69-
%setup -q -n jsonschema-4.15.0
70-
cd %{_builddir}/jsonschema-4.15.0
69+
%setup -q -n jsonschema-4.16.0
70+
cd %{_builddir}/jsonschema-4.16.0
7171
pushd ..
72-
cp -a jsonschema-4.15.0 buildavx2
72+
cp -a jsonschema-4.16.0 buildavx2
7373
popd
7474

7575
%build
7676
export http_proxy=http://127.0.0.1:9/
7777
export https_proxy=http://127.0.0.1:9/
7878
export no_proxy=localhost,127.0.0.1,0.0.0.0
7979
export LANG=C.UTF-8
80-
export SOURCE_DATE_EPOCH=1661983037
80+
export SOURCE_DATE_EPOCH=1666740963
8181
export GCC_IGNORE_WERROR=1
8282
export AR=gcc-ar
8383
export RANLIB=gcc-ranlib
@@ -89,8 +89,8 @@ export CXXFLAGS="$CXXFLAGS -O3 -ffat-lto-objects -flto=auto "
8989
export MAKEFLAGS=%{?_smp_mflags}
9090
python3 -m build --wheel --skip-dependency-check --no-isolation
9191
pushd ../buildavx2/
92-
export CFLAGS="$CFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 -msse2avx"
93-
export CXXFLAGS="$CXXFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 -msse2avx "
92+
export CFLAGS="$CFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
93+
export CXXFLAGS="$CXXFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
9494
export FFLAGS="$FFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
9595
export FCFLAGS="$FCFLAGS -m64 -march=x86-64-v3 "
9696
export LDFLAGS="$LDFLAGS -m64 -march=x86-64-v3 "
@@ -109,8 +109,8 @@ pytest || :
109109
export MAKEFLAGS=%{?_smp_mflags}
110110
rm -rf %{buildroot}
111111
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-jsonschema
112-
cp %{_builddir}/jsonschema-%{version}/COPYING %{buildroot}/usr/share/package-licenses/pypi-jsonschema/2de1a0a3674903238a664ace5d3acc66a7d546c7
113-
cp %{_builddir}/jsonschema-%{version}/json/LICENSE %{buildroot}/usr/share/package-licenses/pypi-jsonschema/6808b97edf6d2c189571af702b95916168ff7db8
112+
cp %{_builddir}/jsonschema-%{version}/COPYING %{buildroot}/usr/share/package-licenses/pypi-jsonschema/2de1a0a3674903238a664ace5d3acc66a7d546c7 || :
113+
cp %{_builddir}/jsonschema-%{version}/json/LICENSE %{buildroot}/usr/share/package-licenses/pypi-jsonschema/6808b97edf6d2c189571af702b95916168ff7db8 || :
114114
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
115115
echo ----[ mark ]----
116116
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :

release

Lines changed: 1 addition & 1 deletion
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
90
1+
91

upstream

Lines changed: 1 addition & 1 deletion
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
4577187dc584f0529ea0fe5563ec3d70ee09a23b/jsonschema-4.15.0.tar.gz
1+
912d562c1394408dca582e14843e3245df2f3827/jsonschema-4.16.0.tar.gz

versions

Lines changed: 1 addition & 1 deletion
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
4.15.0
1+
4.16.0

0 commit comments

Comments
 (0)