Skip to content

Commit e2f5a3b

Browse files
committed
Rename from pre_commit to pypi-pre_commit
0 parents  commit e2f5a3b

17 files changed

+245
-0
lines changed

.gitignore

+19
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,19 @@
1+
.*~
2+
*~
3+
*.info
4+
*.mod
5+
*.swp
6+
.repo-index
7+
*.log
8+
build.log.round*
9+
*.tar.*
10+
*.tgz
11+
!*.tar.*.*
12+
*.zip
13+
*.jar
14+
*.pom
15+
*.xml
16+
commitmsg
17+
results/
18+
rpms/
19+
for-review.txt

Makefile

+5
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,5 @@
1+
PKG_NAME := pypi-pre_commit
2+
URL = https://files.pythonhosted.org/packages/8e/e2/a5c93bd312072003117408cf87e2cb7dcf4992d28ce3cab9bc5eeabecf43/pre_commit-2.16.0.tar.gz
3+
ARCHIVES =
4+
5+
include ../common/Makefile.common

buildreq_add

+2
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,2 @@
1+
# This file contains additional build requirements that did not get
2+
# picked up automatically. One name per line, no whitespace.

buildreq_ban

+2
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,2 @@
1+
# This file contains build requirements that get picked up but are
2+
# undesirable. One entry per line, no whitespace.

buildreq_cache

+7
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,7 @@
1+
2.16.0
2+
pypi(cfgv)
3+
pypi(identify)
4+
pypi(nodeenv)
5+
pypi(pyyaml)
6+
pypi(toml)
7+
pypi(virtualenv)

excludes

+2
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,2 @@
1+
# This file contains the output files that need %exclude. Full path
2+
# names, one per line.

options.conf

+66
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,66 @@
1+
[package]
2+
name = pypi-pre_commit
3+
url = https://files.pythonhosted.org/packages/8e/e2/a5c93bd312072003117408cf87e2cb7dcf4992d28ce3cab9bc5eeabecf43/pre_commit-2.16.0.tar.gz
4+
archives =
5+
giturl = https://github.com/pre-commit/pre-commit
6+
domain =
7+
alias =
8+
9+
[autospec]
10+
# build 32 bit libraries
11+
32bit = false
12+
# allow package to build with test failures
13+
allow_test_failures = false
14+
# unset %build ld_as_needed variable
15+
asneeded = false
16+
# this package is trusted enough to automatically update (used by other tools)
17+
autoupdate = true
18+
# extend flags with '-std=gnu++98
19+
broken_c++ = false
20+
# disable parallelization during build
21+
broken_parallel_build = false
22+
# this package is a library compatibility package and only ships versioned library files
23+
compat = false
24+
# set conservative build flags
25+
conservative_flags = false
26+
# dev package requires the extras to be installed
27+
dev_requires_extras = false
28+
# pass -ffast-math to compiler
29+
fast-math = false
30+
# optimize build for speed over size
31+
funroll-loops = false
32+
# set flags to smallest -02 flags possible
33+
insecure_build = false
34+
# do not remove static libraries
35+
keepstatic = false
36+
# do not require autostart subpackage
37+
no_autostart = false
38+
# do not generate debuginfo for this package
39+
nodebug = false
40+
# disable stripping binaries
41+
nostrip = false
42+
# configure build also for openmpi
43+
openmpi = false
44+
# optimize build for size over speed
45+
optimize_size = false
46+
# set profile for pgo
47+
pgo = false
48+
# set flags for security-sensitive builds
49+
security_sensitive = false
50+
# package is only used by servers
51+
server = false
52+
# do not run test suite
53+
skip_tests = false
54+
# add .so files to the lib package instead of dev
55+
so_to_lib = false
56+
# configure build for avx2
57+
use_avx2 = false
58+
# configure build for avx512
59+
use_avx512 = false
60+
# add clang flags
61+
use_clang = false
62+
# configure build for lto
63+
use_lto = true
64+
# require package verification for build
65+
verify_required = false
66+

pkgconfig_add

+2
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,2 @@
1+
# This file contains additional pkgconfig build requirements that did
2+
# not get picked up automatically. One name per line, no whitespace.

pkgconfig_ban

+2
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,2 @@
1+
# This file contains pkgconfig build requirements that get picked up
2+
# but are undesirable. One entry per line, no whitespace.

pypi-pre_commit.spec

+125
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,125 @@
1+
#
2+
# This file is auto-generated. DO NOT EDIT
3+
# Generated by: autospec.py
4+
#
5+
Name : pypi-pre_commit
6+
Version : 2.16.0
7+
Release : 13
8+
URL : https://files.pythonhosted.org/packages/8e/e2/a5c93bd312072003117408cf87e2cb7dcf4992d28ce3cab9bc5eeabecf43/pre_commit-2.16.0.tar.gz
9+
Source0 : https://files.pythonhosted.org/packages/8e/e2/a5c93bd312072003117408cf87e2cb7dcf4992d28ce3cab9bc5eeabecf43/pre_commit-2.16.0.tar.gz
10+
Summary : A framework for managing and maintaining multi-language pre-commit hooks.
11+
Group : Development/Tools
12+
License : MIT
13+
Requires: pypi-pre_commit-bin = %{version}-%{release}
14+
Requires: pypi-pre_commit-license = %{version}-%{release}
15+
Requires: pypi-pre_commit-python = %{version}-%{release}
16+
Requires: pypi-pre_commit-python3 = %{version}-%{release}
17+
BuildRequires : buildreq-distutils3
18+
Provides: pre_commit
19+
Provides: pre_commit-python
20+
Provides: pre_commit-python3
21+
BuildRequires : buildreq-golang
22+
BuildRequires : pypi(cfgv)
23+
BuildRequires : pypi(identify)
24+
BuildRequires : pypi(nodeenv)
25+
BuildRequires : pypi(pyyaml)
26+
BuildRequires : pypi(toml)
27+
BuildRequires : pypi(virtualenv)
28+
29+
%description
30+
[![Build Status](https://dev.azure.com/asottile/asottile/_apis/build/status/pre-commit.pre-commit?branchName=master)](https://dev.azure.com/asottile/asottile/_build/latest?definitionId=21&branchName=master)
31+
[![Azure DevOps coverage](https://img.shields.io/azure-devops/coverage/asottile/asottile/21/master.svg)](https://dev.azure.com/asottile/asottile/_build/latest?definitionId=21&branchName=master)
32+
[![pre-commit.ci status](https://results.pre-commit.ci/badge/github/pre-commit/pre-commit/master.svg)](https://results.pre-commit.ci/latest/github/pre-commit/pre-commit/master)
33+
34+
%package bin
35+
Summary: bin components for the pypi-pre_commit package.
36+
Group: Binaries
37+
Requires: pypi-pre_commit-license = %{version}-%{release}
38+
39+
%description bin
40+
bin components for the pypi-pre_commit package.
41+
42+
43+
%package license
44+
Summary: license components for the pypi-pre_commit package.
45+
Group: Default
46+
47+
%description license
48+
license components for the pypi-pre_commit package.
49+
50+
51+
%package python
52+
Summary: python components for the pypi-pre_commit package.
53+
Group: Default
54+
Requires: pypi-pre_commit-python3 = %{version}-%{release}
55+
56+
%description python
57+
python components for the pypi-pre_commit package.
58+
59+
60+
%package python3
61+
Summary: python3 components for the pypi-pre_commit package.
62+
Group: Default
63+
Requires: python3-core
64+
Provides: pypi(pre_commit)
65+
Requires: pypi(cfgv)
66+
Requires: pypi(identify)
67+
Requires: pypi(nodeenv)
68+
Requires: pypi(pyyaml)
69+
Requires: pypi(toml)
70+
Requires: pypi(virtualenv)
71+
72+
%description python3
73+
python3 components for the pypi-pre_commit package.
74+
75+
76+
%prep
77+
%setup -q -n pre_commit-2.16.0
78+
cd %{_builddir}/pre_commit-2.16.0
79+
80+
%build
81+
export http_proxy=http://127.0.0.1:9/
82+
export https_proxy=http://127.0.0.1:9/
83+
export no_proxy=localhost,127.0.0.1,0.0.0.0
84+
export LANG=C.UTF-8
85+
export SOURCE_DATE_EPOCH=1641471210
86+
export GCC_IGNORE_WERROR=1
87+
export AR=gcc-ar
88+
export RANLIB=gcc-ranlib
89+
export NM=gcc-nm
90+
export CFLAGS="$CFLAGS -O3 -ffat-lto-objects -flto=auto "
91+
export FCFLAGS="$FFLAGS -O3 -ffat-lto-objects -flto=auto "
92+
export FFLAGS="$FFLAGS -O3 -ffat-lto-objects -flto=auto "
93+
export CXXFLAGS="$CXXFLAGS -O3 -ffat-lto-objects -flto=auto "
94+
export MAKEFLAGS=%{?_smp_mflags}
95+
python3 setup.py build
96+
97+
%install
98+
export MAKEFLAGS=%{?_smp_mflags}
99+
rm -rf %{buildroot}
100+
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-pre_commit
101+
cp %{_builddir}/pre_commit-2.16.0/LICENSE %{buildroot}/usr/share/package-licenses/pypi-pre_commit/0a1b7c6ad0735b8a94231652bab67240e4b834f6
102+
python3 -tt setup.py build install --root=%{buildroot}
103+
echo ----[ mark ]----
104+
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
105+
echo ----[ mark ]----
106+
107+
%files
108+
%defattr(-,root,root,-)
109+
110+
%files bin
111+
%defattr(-,root,root,-)
112+
/usr/bin/pre-commit
113+
/usr/bin/pre-commit-validate-config
114+
/usr/bin/pre-commit-validate-manifest
115+
116+
%files license
117+
%defattr(0644,root,root,0755)
118+
/usr/share/package-licenses/pypi-pre_commit/0a1b7c6ad0735b8a94231652bab67240e4b834f6
119+
120+
%files python
121+
%defattr(-,root,root,-)
122+
123+
%files python3
124+
%defattr(-,root,root,-)
125+
/usr/lib/python3*/*

release

+1
Original file line numberDiff line numberDiff line change
@@ -0,0 +1 @@
1+
13

requires_add

+2
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,2 @@
1+
# This file contains additional runtime requirements that did not get
2+
# picked up automatically. One name per line, no whitespace.

requires_ban

+2
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,2 @@
1+
# This file contains runtime requirements that get picked up but are
2+
# undesirable. One entry per line, no whitespace.

testresults

+5
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,5 @@
1+
Total : 0
2+
Pass : 0
3+
Fail : 0
4+
Skip : 0
5+
XFail : 0

upstream

+1
Original file line numberDiff line numberDiff line change
@@ -0,0 +1 @@
1+
79c74fb4a634e5e84ee3f3e000ad674702139562/pre_commit-2.16.0.tar.gz

versions

+1
Original file line numberDiff line numberDiff line change
@@ -0,0 +1 @@
1+
2.16.0

whatrequires

+1
Original file line numberDiff line numberDiff line change
@@ -0,0 +1 @@
1+
# This file contains recursive sources that require this package

0 commit comments

Comments
 (0)