Skip to content

Commit 539d99f

Browse files
authored
Merge pull request #16 from cspr-rad/update-casper-node
2 parents ba58f48 + ae70029 commit 539d99f

File tree

2 files changed

+7
-6
lines changed

2 files changed

+7
-6
lines changed

Diff for: nixos/modules/casper-node.nix

+3-2
Original file line numberDiff line numberDiff line change
@@ -11,7 +11,8 @@ let
1111

1212
mapDotsToUnderscore = lib.stringAsChars (c: if c == "." then "_" else c);
1313
versionsAndHashes = {
14-
"1.5.6" = "sha256-2N2vPKHLKV32RzzZPV004hWH1/lbeZUf3WofTVm+ZZI=";
14+
"1.5.6" = lib.warn "1.5.6 has a security vulnerability, please use 1.5.7" "sha256-2N2vPKHLKV32RzzZPV004hWH1/lbeZUf3WofTVm+ZZI=";
15+
"1.5.7" = "sha256-apV8lENP1Xnnud8Pm4qy7C4QoNFweJc6eUDmnctoZz4=";
1516
};
1617
defaultConfigsSrc = {
1718
"production" =
@@ -35,7 +36,7 @@ in
3536
{
3637
options.services.casper-node = {
3738

38-
enable = mkEnableOption ("casper-node");
39+
enable = mkEnableOption "casper-node";
3940

4041
package = mkOption {
4142
type = types.package;

Diff for: pkgs/casper-node/default.nix

+4-4
Original file line numberDiff line numberDiff line change
@@ -7,16 +7,16 @@
77
}:
88
rustPlatform.buildRustPackage rec {
99
pname = "casper-node";
10-
version = "1.5.6";
10+
version = "1.5.7";
1111

1212
src = fetchFromGitHub {
1313
owner = "casper-network";
1414
repo = "casper-node";
15-
rev = "v${version}";
16-
sha256 = "sha256-Jm5f8gzX5HYkQMjEI4dV3ooVPyxhpf/lGyryyuAapqI=";
15+
rev = "release-${version}";
16+
hash = "sha256-4il4mGHQNWfUvN6siej9DTzGTJF5l+O1a9nwbHlB3Q8=";
1717
};
1818

19-
cargoHash = "sha256-7yQcPsv7rSZUwWPDFrmeKiU/CKaw1l39Z1LmUSiHLSc=";
19+
cargoHash = "sha256-AbxeP9GRH8lQsHwYiErh/SaAqu1dvTcwaasL0v7xCoU=";
2020

2121
nativeBuildInputs = [ pkg-config cmake ];
2222
buildInputs = [ openssl.dev ];

0 commit comments

Comments
 (0)