Skip to content

Commit b299730

Browse files
authored
Merge pull request #18 from cspr-rad/refactorings
refactor sha256 -> hash, remove unused packages, add casper-node_2 ci check, update flake inputs
2 parents 69200f4 + f3e88e6 commit b299730

File tree

4 files changed

+20
-11
lines changed

4 files changed

+20
-11
lines changed

Diff for: .github/workflows/check.yml

+12
Original file line numberDiff line numberDiff line change
@@ -40,6 +40,18 @@ jobs:
4040
if: matrix.os == 'macos-14'
4141
run: nix build -L --no-link --show-trace .#packages.aarch64-darwin.casper-node
4242

43+
- name: casper-node_2 (x86_64-linux)
44+
if: matrix.os == 'ubuntu-latest'
45+
run: nix build -L --no-link --show-trace .#packages.x86_64-linux.casper-node_2
46+
47+
- name: casper-node_2 (x86_64-darwin)
48+
if: matrix.os == 'macos-latest'
49+
run: nix build -L --no-link --show-trace .#packages.x86_64-darwin.casper-node_2
50+
51+
- name: casper-node_2 aarch64-darwin
52+
if: matrix.os == 'macos-14'
53+
run: nix build -L --no-link --show-trace .#packages.aarch64-darwin.casper-node_2
54+
4355
- name: casper-node-launcher (x86_64-linux)
4456
if: matrix.os == 'ubuntu-latest'
4557
run: nix build -L --no-link --show-trace .#packages.x86_64-linux.casper-node-launcher

Diff for: flake.lock

+6-6
Some generated files are not rendered by default. Learn more about customizing how changed files appear on GitHub.

Diff for: pkgs/casper-node-launcher/default.nix

+1-4
Original file line numberDiff line numberDiff line change
@@ -1,8 +1,5 @@
11
{ rustPlatform
22
, fetchFromGitHub
3-
, makeWrapper
4-
, casper-node
5-
, lib
63
}:
74
rustPlatform.buildRustPackage rec {
85
pname = "casper-node-launcher";
@@ -12,7 +9,7 @@ rustPlatform.buildRustPackage rec {
129
owner = "casper-network";
1310
repo = pname;
1411
rev = "v${version}";
15-
sha256 = "sha256-KDdeLLeRJKoxxPTs4PnhjyjxI+Xffl/AszSzQbx55+E=";
12+
hash = "sha256-KDdeLLeRJKoxxPTs4PnhjyjxI+Xffl/AszSzQbx55+E=";
1613
};
1714

1815
cargoHash = "sha256-19iOBjy3U+zY5kM7GOX1Thq8+gh+ohMoYc0+ALGIzGA=";

Diff for: pkgs/casper-node/2.nix

+1-1
Original file line numberDiff line numberDiff line change
@@ -13,7 +13,7 @@ rustPlatform.buildRustPackage rec {
1313
owner = "casper-network";
1414
repo = "casper-node";
1515
rev = "feat-${version}";
16-
sha256 = "sha256-rk4teBZ42yJVNSRV07Xg10PtA1JsDG59jdNsVegZnzw=";
16+
hash = "sha256-rk4teBZ42yJVNSRV07Xg10PtA1JsDG59jdNsVegZnzw=";
1717
};
1818

1919
cargoHash = "sha256-jyJsFRRCr/K2z4cfqblmWQK2q2TVP+3osWqAzk9S2sQ=";

0 commit comments

Comments
 (0)