Skip to content

Commit 8f4857d

Browse files
committed
meson.build: use 'gtest' protocol for unit tests
this gives better output on failures
1 parent 22e40de commit 8f4857d

File tree

1 file changed

+3
-1
lines changed

1 file changed

+3
-1
lines changed

meson.build

Lines changed: 3 additions & 1 deletion
Original file line numberDiff line numberDiff line change
@@ -1,7 +1,7 @@
11
project('auracle', 'cpp',
22
version : '0',
33
license : 'MIT',
4-
meson_version : '>=0.50',
4+
meson_version : '>=0.55',
55
default_options : [
66
'cpp_std=c++17',
77
'warning_level=2',
@@ -148,6 +148,7 @@ test(
148148
src/aur/response_test.cc
149149
'''.split()),
150150
dependencies : [abseil, gtest, gmock, libaur]),
151+
protocol : 'gtest',
151152
suite : 'libaur')
152153

153154
test(
@@ -163,6 +164,7 @@ test(
163164
src/auracle/sort_test.cc
164165
'''.split()),
165166
dependencies : [abseil, gtest, gmock, libauracle]),
167+
protocol : 'gtest',
166168
suite : 'libauracle')
167169

168170
# integration tests

0 commit comments

Comments
 (0)