Skip to content

Commit c7c9af6

Browse files
rimruldscho
authored andcommitted
pcre2: update to 10.44
Signed-off-by: Matthias Aßhauer <[email protected]> Signed-off-by: Johannes Schindelin <[email protected]>
1 parent 62e4f9d commit c7c9af6

4 files changed

+38
-38
lines changed

Diff for: pcre2/0001-Allow-building-an-MSYS-DLL.patch

+2-2
Original file line numberDiff line numberDiff line change
@@ -1,4 +1,4 @@
1-
From e13f715e224c3a30159e459b37dc2a877beea246 Mon Sep 17 00:00:00 2001
1+
From 59176104933cb63074a9b611cb4669770c7fc0a3 Mon Sep 17 00:00:00 2001
22
From: Johannes Schindelin <[email protected]>
33
Date: Tue, 13 Dec 2022 15:18:52 +0100
44
Subject: [PATCH 1/3] Allow building an MSYS DLL
@@ -9,7 +9,7 @@ Signed-off-by: Johannes Schindelin <[email protected]>
99
1 file changed, 1 insertion(+), 1 deletion(-)
1010

1111
diff --git a/configure.ac b/configure.ac
12-
index 77b77f3..bd51a81 100644
12+
index 6091ea4..9afc110 100644
1313
--- a/configure.ac
1414
+++ b/configure.ac
1515
@@ -932,7 +932,7 @@ fi

Diff for: pcre2/0002-RunTest-adjust-ISO-8859-1-tests-for-Cygwin.patch

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,4 +1,4 @@
1-
From da1cb5fe906f7b52fd7b3d190ca5fcbf3b6a5436 Mon Sep 17 00:00:00 2001
1+
From 9d466b31c059f7045c5f424d1ddc57438c5f2284 Mon Sep 17 00:00:00 2001
22
From: Johannes Schindelin <[email protected]>
33
Date: Fri, 2 Jun 2017 17:54:57 +0200
44
Subject: [PATCH 2/3] RunTest: adjust ISO-8859-1 tests for Cygwin

Diff for: pcre2/0003-pcre2-10.40-cygwin-jit.patch

+30-30
Original file line numberDiff line numberDiff line change
@@ -1,4 +1,4 @@
1-
From faa46be2353c281ce25f53992d5a2d1fb4f26183 Mon Sep 17 00:00:00 2001
1+
From ded6ccc89556e1bd5ab448f58e3a1103c11bddf5 Mon Sep 17 00:00:00 2001
22
From: Yaakov Selkowitz <[email protected]>
33
Date: Thu, 12 May 2016 20:52:27 -0500
44
Subject: [PATCH 3/3] pcre2-10.40-cygwin-jit
@@ -11,10 +11,10 @@ Originally added in https://cygwin.com/git-cygwin-packages/?p=git/cygwin-package
1111
3 files changed, 36 insertions(+), 36 deletions(-)
1212

1313
diff --git a/src/sljit/sljitConfigInternal.h b/src/sljit/sljitConfigInternal.h
14-
index ce4e7b0..e3f85dc 100644
14+
index de06dd8..67daa14 100644
1515
--- a/src/sljit/sljitConfigInternal.h
1616
+++ b/src/sljit/sljitConfigInternal.h
17-
@@ -603,15 +603,15 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_sw sljit_exec_offset(void* ptr);
17+
@@ -602,15 +602,15 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_sw sljit_exec_offset(void *code);
1818
#define SLJIT_NUMBER_OF_TEMPORARY_REGISTERS 2
1919
#define SLJIT_NUMBER_OF_FLOAT_REGISTERS 15
2020
#define SLJIT_NUMBER_OF_TEMPORARY_FLOAT_REGISTERS 1
@@ -30,14 +30,14 @@ index ce4e7b0..e3f85dc 100644
3030
#define SLJIT_LOCALS_OFFSET_BASE (4 * SSIZE_OF(sw))
3131
-#endif /* !_WIN64 */
3232
+#endif /* !_WIN64 && !__CYGWIN__ */
33-
#define SLJIT_PREF_SHIFT_REG SLJIT_R3
34-
#define SLJIT_MASKED_SHIFT 1
35-
#define SLJIT_MASKED_SHIFT32 1
33+
#define SLJIT_TMP_DEST_REG SLJIT_TMP_R0
34+
#define SLJIT_TMP_MEM_REG SLJIT_TMP_R0
35+
#define SLJIT_TMP_DEST_FREG SLJIT_TMP_FR0
3636
diff --git a/src/sljit/sljitNativeX86_64.c b/src/sljit/sljitNativeX86_64.c
37-
index f313f3f..d0873c4 100644
37+
index 1ab7929..d748fa7 100644
3838
--- a/src/sljit/sljitNativeX86_64.c
3939
+++ b/src/sljit/sljitNativeX86_64.c
40-
@@ -443,7 +443,7 @@ static sljit_u8* generate_put_label_code(struct sljit_put_label *put_label, slji
40+
@@ -447,7 +447,7 @@ static sljit_u8* generate_mov_addr_code(struct sljit_jump *jump, sljit_u8 *code_
4141
return code_ptr;
4242
}
4343

@@ -46,7 +46,7 @@ index f313f3f..d0873c4 100644
4646
typedef struct {
4747
sljit_sw regs[2];
4848
} sljit_sse2_reg;
49-
@@ -457,11 +457,11 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_enter(struct sljit_compiler *compi
49+
@@ -461,11 +461,11 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_enter(struct sljit_compiler *compi
5050
sljit_s32 word_arg_count = 0;
5151
sljit_s32 saved_arg_count = SLJIT_KEPT_SAVEDS_COUNT(options);
5252
sljit_s32 saved_regs_size, tmp, i;
@@ -60,7 +60,7 @@ index f313f3f..d0873c4 100644
6060
sljit_u8 *inst;
6161

6262
CHECK_ERROR();
63-
@@ -500,7 +500,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_enter(struct sljit_compiler *compi
63+
@@ -504,7 +504,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_enter(struct sljit_compiler *compi
6464
PUSH_REG(reg_lmap[i]);
6565
}
6666

@@ -69,7 +69,7 @@ index f313f3f..d0873c4 100644
6969
local_size += SLJIT_LOCALS_OFFSET;
7070
saved_float_regs_size = GET_SAVED_FLOAT_REGISTERS_SIZE(fscratches, fsaveds, sse2_reg);
7171

72-
@@ -508,16 +508,16 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_enter(struct sljit_compiler *compi
72+
@@ -512,16 +512,16 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_enter(struct sljit_compiler *compi
7373
saved_float_regs_offset = ((local_size + 0xf) & ~0xf);
7474
local_size = saved_float_regs_offset + saved_float_regs_size;
7575
}
@@ -89,7 +89,7 @@ index f313f3f..d0873c4 100644
8989
switch (word_arg_count) {
9090
case 0:
9191
tmp = SLJIT_R2;
92-
@@ -532,7 +532,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_enter(struct sljit_compiler *compi
92+
@@ -536,7 +536,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_enter(struct sljit_compiler *compi
9393
tmp = SLJIT_R3;
9494
break;
9595
}
@@ -98,7 +98,7 @@ index f313f3f..d0873c4 100644
9898
switch (word_arg_count + float_arg_count) {
9999
case 0:
100100
tmp = SLJIT_R3;
101-
@@ -547,7 +547,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_enter(struct sljit_compiler *compi
101+
@@ -551,7 +551,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_enter(struct sljit_compiler *compi
102102
tmp = TMP_REG1;
103103
break;
104104
}
@@ -107,7 +107,7 @@ index f313f3f..d0873c4 100644
107107
if (arg_types & SLJIT_ARG_TYPE_SCRATCH_REG) {
108108
if (tmp != SLJIT_R0 + word_arg_count)
109109
EMIT_MOV(compiler, SLJIT_R0 + word_arg_count, 0, tmp, 0);
110-
@@ -557,13 +557,13 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_enter(struct sljit_compiler *compi
110+
@@ -561,13 +561,13 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_enter(struct sljit_compiler *compi
111111
}
112112
word_arg_count++;
113113
} else {
@@ -123,7 +123,7 @@ index f313f3f..d0873c4 100644
123123
}
124124
arg_types >>= SLJIT_ARG_SHIFT;
125125
}
126-
@@ -571,7 +571,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_enter(struct sljit_compiler *compi
126+
@@ -575,7 +575,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_enter(struct sljit_compiler *compi
127127
local_size = ((local_size + saved_regs_size + 0xf) & ~0xf) - saved_regs_size;
128128
compiler->local_size = local_size;
129129

@@ -132,7 +132,7 @@ index f313f3f..d0873c4 100644
132132
if (local_size > 0) {
133133
if (local_size <= 4 * 4096) {
134134
if (local_size > 4096)
135-
@@ -600,12 +600,12 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_enter(struct sljit_compiler *compi
135+
@@ -604,12 +604,12 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_enter(struct sljit_compiler *compi
136136
if (local_size > 0)
137137
EMIT_MOV(compiler, TMP_REG1, 0, SLJIT_MEM1(SLJIT_SP), -local_size);
138138
}
@@ -147,7 +147,7 @@ index f313f3f..d0873c4 100644
147147
if (saved_float_regs_size > 0) {
148148
compiler->mode32 = 1;
149149

150-
@@ -620,7 +620,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_enter(struct sljit_compiler *compi
150+
@@ -624,7 +624,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_enter(struct sljit_compiler *compi
151151
saved_float_regs_offset += 16;
152152
}
153153
}
@@ -156,7 +156,7 @@ index f313f3f..d0873c4 100644
156156

157157
return SLJIT_SUCCESS;
158158
}
159-
@@ -630,23 +630,23 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_set_context(struct sljit_compiler *comp
159+
@@ -634,23 +634,23 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_set_context(struct sljit_compiler *comp
160160
sljit_s32 fscratches, sljit_s32 fsaveds, sljit_s32 local_size)
161161
{
162162
sljit_s32 saved_regs_size;
@@ -185,7 +185,7 @@ index f313f3f..d0873c4 100644
185185

186186
/* Including the return address saved by the call instruction. */
187187
saved_regs_size = GET_SAVED_REGISTERS_SIZE(scratches, saveds - SLJIT_KEPT_SAVEDS_COUNT(options), 1);
188-
@@ -659,13 +659,13 @@ static sljit_s32 emit_stack_frame_release(struct sljit_compiler *compiler, sljit
188+
@@ -663,13 +663,13 @@ static sljit_s32 emit_stack_frame_release(struct sljit_compiler *compiler, sljit
189189
sljit_uw size;
190190
sljit_s32 local_size, i, tmp;
191191
sljit_u8 *inst;
@@ -202,7 +202,7 @@ index f313f3f..d0873c4 100644
202202
saved_float_regs_offset = GET_SAVED_FLOAT_REGISTERS_SIZE(fscratches, fsaveds, sse2_reg);
203203

204204
if (saved_float_regs_offset > 0) {
205-
@@ -685,7 +685,7 @@ static sljit_s32 emit_stack_frame_release(struct sljit_compiler *compiler, sljit
205+
@@ -689,7 +689,7 @@ static sljit_s32 emit_stack_frame_release(struct sljit_compiler *compiler, sljit
206206

207207
compiler->mode32 = 0;
208208
}
@@ -211,7 +211,7 @@ index f313f3f..d0873c4 100644
211211

212212
local_size = compiler->local_size;
213213

214-
@@ -762,7 +762,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_return_to(struct sljit_compiler *c
214+
@@ -766,7 +766,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_return_to(struct sljit_compiler *c
215215
/* Call / return instructions */
216216
/* --------------------------------------------------------------------- */
217217

@@ -221,10 +221,10 @@ index f313f3f..d0873c4 100644
221221
static sljit_s32 call_with_args(struct sljit_compiler *compiler, sljit_s32 arg_types, sljit_s32 *src_ptr)
222222
{
223223
diff --git a/src/sljit/sljitNativeX86_common.c b/src/sljit/sljitNativeX86_common.c
224-
index c2c0421..da8af3d 100644
224+
index ecb7e9b..91dfcc8 100644
225225
--- a/src/sljit/sljitNativeX86_common.c
226226
+++ b/src/sljit/sljitNativeX86_common.c
227-
@@ -95,7 +95,7 @@ static const sljit_u8 freg_map[SLJIT_NUMBER_OF_FLOAT_REGISTERS + 2] = {
227+
@@ -88,7 +88,7 @@ static const sljit_u8 freg_map[SLJIT_NUMBER_OF_FLOAT_REGISTERS + 2] = {
228228
/* Note: r12 & 0x7 == 0b100, which decoded as SIB byte present
229229
Note: avoid to use r12 and r13 for memory addressing
230230
therefore r12 is better to be a higher saved register. */
@@ -233,7 +233,7 @@ index c2c0421..da8af3d 100644
233233
/* Args: rdi(=7), rsi(=6), rdx(=2), rcx(=1), r8, r9. Scratches: rax(=0), r10, r11 */
234234
static const sljit_u8 reg_map[SLJIT_NUMBER_OF_REGISTERS + 4] = {
235235
0, 0, 6, 7, 1, 8, 11, 10, 12, 5, 13, 14, 15, 3, 4, 2, 9
236-
@@ -130,7 +130,7 @@ static const sljit_u8 freg_lmap[SLJIT_NUMBER_OF_FLOAT_REGISTERS + 2] = {
236+
@@ -123,7 +123,7 @@ static const sljit_u8 freg_lmap[SLJIT_NUMBER_OF_FLOAT_REGISTERS + 2] = {
237237
#define REX_B 0x41
238238
#define REX 0x40
239239

@@ -242,7 +242,7 @@ index c2c0421..da8af3d 100644
242242
#define HALFWORD_MAX 0x7fffffffl
243243
#define HALFWORD_MIN -0x80000000l
244244
#else
245-
@@ -1228,7 +1228,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_op0(struct sljit_compiler *compile
245+
@@ -1377,7 +1377,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_op0(struct sljit_compiler *compile
246246
case SLJIT_DIV_UW:
247247
case SLJIT_DIV_SW:
248248
#if (defined SLJIT_CONFIG_X86_64 && SLJIT_CONFIG_X86_64)
@@ -251,7 +251,7 @@ index c2c0421..da8af3d 100644
251251
SLJIT_ASSERT(
252252
reg_map[SLJIT_R0] == 0
253253
&& reg_map[SLJIT_R1] == 2
254-
@@ -1245,7 +1245,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_op0(struct sljit_compiler *compile
254+
@@ -1394,7 +1394,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_op0(struct sljit_compiler *compile
255255

256256
op = GET_OPCODE(op);
257257
if ((op | 0x2) == SLJIT_DIV_UW) {
@@ -260,7 +260,7 @@ index c2c0421..da8af3d 100644
260260
EMIT_MOV(compiler, TMP_REG1, 0, SLJIT_R1, 0);
261261
inst = emit_x86_instruction(compiler, 1, SLJIT_R1, 0, SLJIT_R1, 0);
262262
#else
263-
@@ -1256,7 +1256,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_op0(struct sljit_compiler *compile
263+
@@ -1405,7 +1405,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_op0(struct sljit_compiler *compile
264264
}
265265

266266
if ((op | 0x2) == SLJIT_DIV_SW) {
@@ -269,7 +269,7 @@ index c2c0421..da8af3d 100644
269269
EMIT_MOV(compiler, TMP_REG1, 0, SLJIT_R1, 0);
270270
#endif
271271

272-
@@ -1281,7 +1281,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_op0(struct sljit_compiler *compile
272+
@@ -1430,7 +1430,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_op0(struct sljit_compiler *compile
273273
inst[0] = GROUP_F7;
274274
inst[1] = MOD_REG | ((op >= SLJIT_DIVMOD_UW) ? reg_map[TMP_REG1] : reg_map[SLJIT_R1]);
275275
#else /* !SLJIT_CONFIG_X86_32 */
@@ -278,7 +278,7 @@ index c2c0421..da8af3d 100644
278278
size = (!compiler->mode32 || op >= SLJIT_DIVMOD_UW) ? 3 : 2;
279279
#else /* !_WIN64 */
280280
size = (!compiler->mode32) ? 3 : 2;
281-
@@ -1289,7 +1289,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_op0(struct sljit_compiler *compile
281+
@@ -1438,7 +1438,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_op0(struct sljit_compiler *compile
282282
inst = (sljit_u8*)ensure_buf(compiler, 1 + size);
283283
FAIL_IF(!inst);
284284
INC_SIZE(size);
@@ -287,7 +287,7 @@ index c2c0421..da8af3d 100644
287287
if (!compiler->mode32)
288288
*inst++ = REX_W | ((op >= SLJIT_DIVMOD_UW) ? REX_B : 0);
289289
else if (op >= SLJIT_DIVMOD_UW)
290-
@@ -1319,7 +1319,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_op0(struct sljit_compiler *compile
290+
@@ -1468,7 +1468,7 @@ SLJIT_API_FUNC_ATTRIBUTE sljit_s32 sljit_emit_op0(struct sljit_compiler *compile
291291
inst[1] |= IDIV;
292292
break;
293293
}

Diff for: pcre2/PKGBUILD

+5-5
Original file line numberDiff line numberDiff line change
@@ -2,7 +2,7 @@
22

33
pkgbase=pcre2
44
pkgname=('pcre2' 'libpcre2_8' 'libpcre2_16' 'libpcre2_32' 'libpcre2posix' 'pcre2-devel')
5-
pkgver=10.43
5+
pkgver=10.44
66
pkgrel=1
77
pkgdesc="A library that implements Perl 5-style regular expressions"
88
arch=('i686' 'x86_64')
@@ -13,11 +13,11 @@ source=(https://github.com/PCRE2project/pcre2/releases/download/${pkgbase}-${pkg
1313
0001-Allow-building-an-MSYS-DLL.patch
1414
0002-RunTest-adjust-ISO-8859-1-tests-for-Cygwin.patch
1515
0003-pcre2-10.40-cygwin-jit.patch)
16-
sha256sums=('e2a53984ff0b07dfdb5ae4486bbb9b21cca8e7df2434096cc9bf1b728c350bcb'
16+
sha256sums=('d34f02e113cf7193a1ebf2770d3ac527088d485d4e047ed10e5d217c6ef5de96'
1717
'SKIP'
18-
'c281d6d726c4119bccfa08479a87d8381df61df5ad365e697cbf68f961ffea71'
19-
'576f96714c30cf011473dc39d79edb8f2deb70df12dbfb2f53dd6986b965178e'
20-
'4199607d30271e5cce9758740d30de564d3375b6da92ba1bbe484bfe980f487e')
18+
'4130d1c668750006a91ad5217f3206642d5d57f4d86ce4465a09dfa3d051f245'
19+
'f1fb2eac8776ad338cdbe1db94050fa785d4ec7fc69f4c658ae26287b89f8acd'
20+
'055755e4eb78bb684110e41980e3b8d7d960cecc370602e72bed0c5b880f4f99')
2121
validpgpkeys=('45F68D54BBE23FB3039B46E59766E084FB0F43D8') # Philip Hazel <[email protected]>
2222

2323
prepare() {

0 commit comments

Comments
 (0)