Skip to content

Commit 21841d3

Browse files
committed
kompute : enable kp_logger and make it static (#8)
1 parent cc05a60 commit 21841d3

File tree

2 files changed

+2
-1
lines changed

2 files changed

+2
-1
lines changed

CMakeLists.txt

+1
Original file line numberDiff line numberDiff line change
@@ -463,6 +463,7 @@ if (LLAMA_KOMPUTE)
463463

464464
if (EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/kompute/CMakeLists.txt")
465465
message(STATUS "Kompute found")
466+
set(KOMPUTE_OPT_LOG_LEVEL Error CACHE STRING "Kompute log level")
466467
add_subdirectory(kompute)
467468

468469
# Compile our shaders

kompute/src/logger/CMakeLists.txt

+1-1
Original file line numberDiff line numberDiff line change
@@ -2,7 +2,7 @@ cmake_minimum_required(VERSION 3.20)
22

33
set(LOGGER_SOURCES Logger.cpp)
44

5-
add_library(kp_logger ${LOGGER_SOURCES})
5+
add_library(kp_logger STATIC ${LOGGER_SOURCES})
66

77
# Define log levels in code
88
add_compile_definitions(KOMPUTE_LOG_LEVEL_TRACE=0)

0 commit comments

Comments
 (0)