Skip to content

Commit c1602d1

Browse files
Deepesh Varatharajanrpurdie
Deepesh Varatharajan
authored andcommitted
rust: Fix build break because of "download-rustc" and "llvm-tools"
>From Rust 1.84, the download-rustc and llvm-tools options were set to True (previously they were False) rust-lang/rust@cce6f03 (download-rustc) rust-lang/rust@38f0c09 (llvm-tools) For tarball sources, the download-rustc option should be False, so it has been reverted back to False. Setting llvm-tools to True caused issues with finding llvm-objcopy, so this has been changed back to False. Upstream-Status: rust-lang/rust#134240 Signed-off-by: Deepesh Varatharajan <[email protected]> Signed-off-by: Richard Purdie <[email protected]>
1 parent 8575041 commit c1602d1

File tree

1 file changed

+2
-0
lines changed

1 file changed

+2
-0
lines changed

meta/recipes-devtools/rust/rust_1.83.0.bb

+2
Original file line numberDiff line numberDiff line change
@@ -147,6 +147,8 @@ python do_configure() {
147147
config.add_section("rust")
148148
config.set("rust", "rpath", e(True))
149149
config.set("rust", "remap-debuginfo", e(True))
150+
config.set("rust", "download-rustc", e(False))
151+
config.set("rust", "llvm-tools", e(False))
150152
config.set("rust", "channel", e(d.expand("${RUST_CHANNEL}")))
151153

152154
# Whether or not to optimize the compiler and standard library

0 commit comments

Comments
 (0)