-
Notifications
You must be signed in to change notification settings - Fork 0
/
Copy path21_Circular_Right_Shift.c
63 lines (56 loc) · 2.13 KB
/
21_Circular_Right_Shift.c
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
/*
Name : Prabhat Kiran
Date : 18th July 2022
Description : WAP to implement Circular right shift.
Sample Input : 1) Enter num: 12
Enter n : 3
2) Enter num: -12
Enter n : 3
Sample Output: 1) Result in Binary: 10000000 00000000 00000000 00000001
2) Result in Binary: 10011111 11111111 11111111 11111110
*/
#include <stdio.h>
int circular_right (int, int); //Function declaration of 'circular_right' to tell the compiler to search for the function definition later in the code.
int print_bits (int); //Function declaration of 'print_bits' to tell the compiler to search for the function definition later in the code.
int main()
{
int num, n, ret;
printf ("Enter num: ");
scanf ("%d", &num);
printf ("Enter n : ");
scanf ("%d", &n);
if ((n >= 0) && (n < 32))
{
ret = circular_right (num, n); //Function call to 'circular_right' with the function arguments 'num' and 'n'.
printf ("Result in Binary: ");
print_bits(ret); //Function call to 'print_bits' with the function arguments 'ret'.
printf ("\n");
}
else
{
printf ("The value of 'n' shall be in the range of 0 to 32.\n");
}
return 0;
}
int circular_right (int num, int n)
{
return (((unsigned int) num >> n) | num << (32 - n));
//'((unsigned int) num << n)' : The bits are right shifted normally. 'unsigned int' type casting is for preventing the MSB from being a sign bit. So, all the vacated bits will be filled with '0'.
//'((num << (32 - n)))' : The LSB side bits are left shifted to position them exactly at the vacated bits on the MSB side.
//'x | y' : The OR operation gives the final result of Circular Right shift.
}
int print_bits (int res)
{
for (int i = 31; i >= 0; i--)
{
if (res & (1 << i)) //If the AND operation is a non-zero value, print "1".
{
printf ("1 ");
}
else //If the AND operation is a zero-value, print "0".
{
printf ("0 ");
}
}
return 1;
}