Skip to content

Commit b4be343

Browse files
committed
treewide: use IPKG_INSTROOT where neccessary
1 parent 9f86488 commit b4be343

File tree

4 files changed

+9
-2
lines changed

4 files changed

+9
-2
lines changed

packages/falter-berlin-admin-keys/Makefile

+3-1
Original file line numberDiff line numberDiff line change
@@ -34,7 +34,9 @@ endef
3434

3535
define Package/falter-berlin-admin-keys/postinst
3636
#!/bin/sh
37-
$${IPKG_INSTROOT}/tmp/falter-berlin-admin-keys/register_keys.sh
37+
if [ -z $${IPKG_INSTROOT} ] ; then
38+
/tmp/falter-berlin-admin-keys/register_keys.sh
39+
fi
3840
endef
3941

4042
$(eval $(call BuildPackage,falter-berlin-admin-keys))

packages/falter-berlin-autoupdate/files/post-inst.sh

+2
Original file line numberDiff line numberDiff line change
@@ -4,6 +4,8 @@
44
# intended. You better shouldn't touch anything here.
55
# shellcheck disable=all
66

7+
[ -z $IPKG_INSTROOT ] || exit 0
8+
79
# if autoupdate is not present in crontab, include it.
810
crontab -l | grep /usr/bin/autoupdate >>/dev/null
911
if [ $? != 0 ]; then

packages/falter-berlin-bbbdigger/files/etc/uci-defaults/90-bbbdigger

+2
Original file line numberDiff line numberDiff line change
@@ -8,6 +8,8 @@
88
#
99
# All other config sections are overwritten with current settings
1010

11+
[ -z $IPKG_INSTROOT ] || exit 0
12+
1113
. /lib/functions.sh
1214

1315
TUNNEL_SRV='_bbb-vpn._udp.berlin.freifunk.net'

packages/falter-berlin-ssid-changer/files/post-inst.sh

+2-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,6 @@
11
#!/bin/sh
2-
#
2+
3+
[ -z $IPKG_INSTROOT ] || exit 0
34

45
# if ssid-changer is not present in crontab, include it.
56
crontab -l | grep ssid-changer >>/dev/null

0 commit comments

Comments
 (0)