Skip to content

Commit

Permalink
chat/py-nbxmpp: Update to 4.4.0
Browse files Browse the repository at this point in the history
Convert to wheel.mk.
Passes self tests.

Upstream NEWS content:

nbxmpp 4.4.0 (22 Oct 2023)

  New

  * Add DiscoInfo.has_identity()
  * JID: Add JID.from_iri()

  Improvements

  * JID: Improve compliance when generating IRIs

  Change

  * Chatstates: Accept chatstates with delay tag

nbxmpp 4.3.3 (28 Aug 2023)

  Improvements

  * JID: Allow comparisons against any object
  * DiscoInfo: Improve discovery if subject is allowed to be modified

  Bug Fixes

  * Don’t expect localpart for bare JIDs

nbxmpp 4.3.2 (04 Jul 2023)

  New

  * SecurityLabels: Add get_label_hash()
  * JID: Add sqlite3 adapter magic method
  * MessageProperties: Add origin_id attribute
  * MessageProperties: Add remote_jid attribute

  Improvements

  * Client: Return only copy of ignored errors
  * CommonError: Add 'by' attribute
  * Moderation: Parse more data

  Bug Fixes

  * HTTP: Add set_accept_certificate()

nbxmpp 4.3.1 (28 May 2023)

  Bug Fixes

  * HTTP: Abort correctly on content overflow
  * Websocket: Always set peer certificate

nbxmpp 4.3.0 (21 May 2023)

  New

  * Add option to force http1
  * Add method to generate XMPP IRIs

  Improvements

  * Lower log level for missing GSSAPI dependency

  Change

  * OMEMO: Add device id and namespace to OMEMOBundle

  Bug Fixes

  * Don’t delete session object in cleanup()
  * HTTP: Don’t accept content encoding (#143)

nbxmpp 4.2.2 (25 Mar 2023)

  Bug Fixes

  * HTTP: Reset attributes on redirect (#141)

nbxmpp 4.2.1 (18 Mar 2023)

  Bug Fixes

  * HTTP: Make sure streams are closed only once (#139)

nbxmpp 4.2.0 (05 Feb 2023)

  New

  * Add support for XEP-0461: Message Replies

  Improvements

  * Add SASLprep profile

  Change

  * Require PyGObject 3.42.0

nbxmpp 4.1.0 (24 Jan 2023)

  Change

  * Port package to pyproject.toml

  Bug Fixes

  * Handle race condition when cancelling request (#136)

nbxmpp 4.0.1 (10 Jan 2023)

  Bug Fixes

  * HTTP: Parse uri with correct flags

nbxmpp 4.0.0 (06 Jan 2023)

  New

  * Add message reactions (XEP-0444) support
  * Add HTTP module

  Change

  * Raise required python version to 3.10
  * Remove example client
  * Port to libsoup3
  * XEP-0392: Update to 0.8.0

nbxmpp 3.2.5 (26 Oct 2022)

  New

  * Add support for XEP-0421

  Bug Fixes

  * MUC: Check correctly for muc subject
  * Client: Don’t override modified certification errors

nbxmpp 3.2.4 (05 Oct 2022)

  Improvements

  * Tasks: Track timeouts within the task

  Bug Fixes

  * MUC: Relax definition of MUC config change

nbxmpp 3.2.3 (28 Sep 2022)

  Bug Fixes

  * TCP: Improve detection of broken connection

nbxmpp 3.2.2 (13 Sep 2022)

  New

  * Expose TLS version and ciphersuite
  * Add stringprep implementation

  Change

  * Add packaging as dependency
  * Use stringprep instead of precis for JID validation

  Bug Fixes

  * Add missing __init__.py to examples

  Notes

  * You can set the env variable NBXMPP_USE_PRECIS to revert back
    to the old behavior.

nbxmpp 3.2.1 (29 Aug 2022)

  Bug Fixes

  * Prepare domain names with UTS46

nbxmpp 3.2.0 (28 Aug 2022)

  New

  * Add support for Extensible SASL Profile (XEP-0388)

  Bug Fixes

  * Set timeout for host-meta http query (#130)

nbxmpp 3.1.1 (27 Jul 2022)

  Improvements

  * Add more datetime test cases

  Performance

  * Use cache when calling JID.new_as_bare()

  Bug Fixes

  * Allow handlers to connect to presence type available

nbxmpp 3.1.0 (28 May 2022)

  New

  * Examples: Allow to connect with different modes

  Bug Fixes

  * Client: Disconnect after stream restart in Login mode

nbxmpp 3.0.2 (18 May 2022)

  Bug Fixes

  * Roster: Raise exception if a full jid is found
  * AdHoc: Don’t raise on empty nodes
  * Roster: Don’t fail when no roster attribute is found
  * #126 Remove redundant wheel dependency

nbxmpp 3.0.1 (09 May 2022)

  Bugfix

  * Fix non-installable release

nbxmpp 3.0.0 (09 May 2022)

  New

  * Add Roster module
  * Add Last Activity module
  * Add EntityTime module
  * Bookmarks: Add extensions support
  * Add Message Moderation
  * Implement SCRAM-SHA-512

  Bugfixes

  * AdHoc: Improve XEP-0050 Compliance
  * Correctly handle RSM count request
  * Correction: Ignore messages where message id == replace id
  * Blocking: Don’t abort processing after parsing unblocks
  * Handle multiple stanza-id elements

  Others

  * Many breaking changes to methods and structs
  • Loading branch information
gdt committed Feb 6, 2025
1 parent fec4287 commit 767fda1
Show file tree
Hide file tree
Showing 2 changed files with 7 additions and 9 deletions.
8 changes: 3 additions & 5 deletions chat/py-nbxmpp/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.10 2024/08/06 23:21:25 gdt Exp $
# $NetBSD: Makefile,v 1.11 2025/02/06 20:45:37 gdt Exp $

DISTNAME= nbxmpp-2.0.6
DISTNAME= nbxmpp-4.4.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= chat python
MASTER_SITES= ${MASTER_SITE_PYPI:=n/nbxmpp/}
Expand All @@ -17,7 +17,5 @@ DEPENDS+= ${PYPKGPREFIX}-precis-i18n>=1.0.0:../../textproc/py-precis-i18n

USE_LANGUAGES= # none

PYTHON_VERSIONS_INCOMPATIBLE= 27

.include "../../lang/python/egg.mk"
.include "../../lang/python/wheel.mk"
.include "../../mk/bsd.pkg.mk"
8 changes: 4 additions & 4 deletions chat/py-nbxmpp/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.10 2024/08/06 23:21:25 gdt Exp $
$NetBSD: distinfo,v 1.11 2025/02/06 20:45:37 gdt Exp $

BLAKE2s (nbxmpp-2.0.6.tar.gz) = d12a293f2298bbffc7030ebe568db45ffb8f50a248bd57b84e5e1a6ad73721b6
SHA512 (nbxmpp-2.0.6.tar.gz) = 258cdc253b91e8550f26236f80fe16ad112c58fd936337a5b11563db8d2535004475ed7bdf5a78172640cd6d6dc86c654f2feb1d4b38a62b92566768c74d65a0
Size (nbxmpp-2.0.6.tar.gz) = 141999 bytes
BLAKE2s (nbxmpp-4.4.0.tar.gz) = 72f58696084bf91697a99c107aa6939e401e5111685b6bd69a661294bddb4a5e
SHA512 (nbxmpp-4.4.0.tar.gz) = c17f2d11c2647159abc7af5b5b2ac85ed95ad2e280477b3e3578ae6bbff767433306edd37796c8947e892bbf6cf9846dcc5af30d5980de3f03bc37e9a8be8330
Size (nbxmpp-4.4.0.tar.gz) = 170831 bytes

0 comments on commit 767fda1

Please sign in to comment.