Skip to content

Commit

Permalink
chore: release notes 3.8.0 (#994)
Browse files Browse the repository at this point in the history
## Description

The release notes for the upcoming 3.8.0 release.
  • Loading branch information
aleksuss authored Feb 5, 2025
1 parent 1b4083c commit 1a14d90
Show file tree
Hide file tree
Showing 5 changed files with 46 additions and 7 deletions.
9 changes: 7 additions & 2 deletions .github/workflows/builds.yml
Original file line number Diff line number Diff line change
Expand Up @@ -30,9 +30,9 @@ jobs:
cargo make --profile ${{ matrix.profile }} build-xcc-docker
- run: ls -lH bin/aurora-*${{ matrix.profile }}.wasm
- name: Upload aurora-${{ matrix.profile }}.wasm artifact
uses: actions/upload-artifact@v3
uses: actions/upload-artifact@v4
with:
name: contracts
name: contract-${{ matrix.profile }}
path: bin/aurora*${{ matrix.profile }}.wasm

publish:
Expand All @@ -42,6 +42,10 @@ jobs:
steps:
- name: Download artifacts
uses: actions/download-artifact@v4
with:
path: contracts
pattern: contract-*
merge-multiple: true
- run: ls -la contracts
- name: Publish contracts for ${{ github.ref }} release
uses: svenstaro/upload-release-action@v2
Expand All @@ -50,6 +54,7 @@ jobs:
file: contracts/aurora*.wasm
repo_token: ${{ secrets.GITHUB_TOKEN }}
file_glob: true
overwrite: true
env:
CARGO_TERM_COLOR: always
CARGO_INCREMENTAL: 0
38 changes: 36 additions & 2 deletions CHANGES.md
Original file line number Diff line number Diff line change
Expand Up @@ -7,6 +7,39 @@ and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0

## [Unreleased]

## [3.8.0] 2025-02-05

### Changes

- Bumped the SputnikVM up to 0.46.1-aurora by [@mrLSD]. ([#966])
- The nightly rust compiler has been replaced with stable by [@aleksuss]. ([#977])
- Added changes regarding bumping the `primitive-types` crate by [@mrLSD]. ([#982])
- The code coverage by clippy has been extended by [@aleksuss]. ([#984])
- The code is changed by the clippy suggestions from the toolchain 1.84.0 by [@mrLSD]. ([#986])
- The precompile `exitToNear` now is compatible with the OMNI bridge by [@aleksuss]. ([#992])

### Fixes

- Added optimisations to the `AccountId` creation methods by [@aleksuss]. ([#985])
- The `README.md` has been actualized by [@aleksuss]. ([#978])
- Modified CI scripts by [@aleksuss]. ([#969], [#973], [#975], [#976], [#981])
- Fixed the vulnerability in the `remove_relayer_key` transaction by [@aleksuss]. ([#972])

[#966]: https://github.com/aurora-is-near/aurora-engine/pull/966
[#969]: https://github.com/aurora-is-near/aurora-engine/pull/969
[#972]: https://github.com/aurora-is-near/aurora-engine/pull/972
[#973]: https://github.com/aurora-is-near/aurora-engine/pull/973
[#975]: https://github.com/aurora-is-near/aurora-engine/pull/975
[#976]: https://github.com/aurora-is-near/aurora-engine/pull/976
[#977]: https://github.com/aurora-is-near/aurora-engine/pull/977
[#978]: https://github.com/aurora-is-near/aurora-engine/pull/978
[#981]: https://github.com/aurora-is-near/aurora-engine/pull/981
[#982]: https://github.com/aurora-is-near/aurora-engine/pull/982
[#984]: https://github.com/aurora-is-near/aurora-engine/pull/984
[#985]: https://github.com/aurora-is-near/aurora-engine/pull/985
[#986]: https://github.com/aurora-is-near/aurora-engine/pull/986
[#992]: https://github.com/aurora-is-near/aurora-engine/pull/992

## [3.7.0] 2024-10-09

### Additions
Expand All @@ -28,7 +61,7 @@ and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0
- Removed duplicated `test` task in the `README.md` by [@dwiekawki]. ([#943])
- Fixed some typos in the `README.md` and `Cargo.toml` by [@DemoYeti]. ([#945]) ([#946])
- Fixed exceeded prepaid gas error in the `mirror_erc20_token` transaction by [@aleksuss] ([#951])
- Modified `hardhat.config.js` to support contract verification by [@spilin] ([#958])q
- Modified `hardhat.config.js` to support contract verification by [@spilin] ([#958])

[#926]: https://github.com/aurora-is-near/aurora-engine/pull/926
[#930]: https://github.com/aurora-is-near/aurora-engine/pull/930
Expand Down Expand Up @@ -697,7 +730,8 @@ struct SubmitResult {

## [1.0.0] - 2021-05-12

[Unreleased]: https://github.com/aurora-is-near/aurora-engine/compare/3.7.0...develop
[Unreleased]: https://github.com/aurora-is-near/aurora-engine/compare/3.8.0...develop
[3.8.0]: https://github.com/aurora-is-near/aurora-engine/compare/3.7.0...3.8.0
[3.7.0]: https://github.com/aurora-is-near/aurora-engine/compare/3.6.4...3.7.0
[3.6.4]: https://github.com/aurora-is-near/aurora-engine/compare/3.6.3...3.6.4
[3.6.3]: https://github.com/aurora-is-near/aurora-engine/compare/3.6.2...3.6.3
Expand Down
2 changes: 1 addition & 1 deletion Cargo.lock

Some generated files are not rendered by default. Learn more about how customized files appear on GitHub.

2 changes: 1 addition & 1 deletion VERSION
Original file line number Diff line number Diff line change
@@ -1 +1 @@
3.7.0
3.8.0
2 changes: 1 addition & 1 deletion engine/Cargo.toml
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = "aurora-engine"
version = "3.7.0"
version = "3.8.0"
authors.workspace = true
edition.workspace = true
homepage.workspace = true
Expand Down

0 comments on commit 1a14d90

Please sign in to comment.