Skip to content

Commit 25a513e

Browse files
committed
pypi-jsonschema: Autospec creation for update from version 4.16.0 to version 4.17.3
Julian Berman (28): Make it clearer that format: regex is Python regexes in this implementation. Better wording. Bold is loud. Ignore PyCQA/flake8-bugbear#287. Fix the grammar on ErrorTree's repr when it has 1 error. Deprecate the CLI (via import or running normally). Update the Draft 3 and 4 metaschemas. Enable format validation by default in check_schema. Re-add the second test for importing jsonschema.cli Satisfy mypy's new default. Squashed 'json/' changes from ed0b855e7..0fa89d2ab Squashed 'json/' changes from 0fa89d2ab..9251ebff1 Emit a better error message for unevaluatedProperties with a subschema. Un-bundle single-vocabulary meta-schemas. Update docs requirements. Temporarily evade sphinx-doc/sphinxext-opengraph#87 Suppress epub warnings for duplicated ToC entries. Run more things with 3.11 in CI. Skip the rest of the docs builds on Windows in CI. Remove making believe we are ReadTheDocs in CI builds. v4.17.1 -> CHANGELOG Squashed 'json/' changes from 9251ebff1..78c888273 Minor fix for test case class names (for format tests). Empty strings are not valid relative JSON pointers. Durations without trailing units aren't valid durations. Update pre-commit hooks. Try fixing more Sphinx refs which fail only on Ubuntu... Fix instantiating validators with cached refs-to-bool schemas.
1 parent 2124d92 commit 25a513e

File tree

7 files changed

+16
-16
lines changed

7 files changed

+16
-16
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-jsonschema
2-
URL = https://files.pythonhosted.org/packages/cf/54/8923ba38b5145f2359d57e5516715392491d674c83f446cd4cd133eeb4d6/jsonschema-4.16.0.tar.gz
2+
URL = https://files.pythonhosted.org/packages/36/3d/ca032d5ac064dff543aa13c984737795ac81abc9fb130cd2fcff17cfabc7/jsonschema-4.17.3.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

buildreq_cache

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,2 +1,2 @@
1-
4.16.0
1+
4.17.3
22
pypi-pytest

options.conf

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-jsonschema
3-
url = https://files.pythonhosted.org/packages/cf/54/8923ba38b5145f2359d57e5516715392491d674c83f446cd4cd133eeb4d6/jsonschema-4.16.0.tar.gz
3+
url = https://files.pythonhosted.org/packages/36/3d/ca032d5ac064dff543aa13c984737795ac81abc9fb130cd2fcff17cfabc7/jsonschema-4.17.3.tar.gz
44
archives =
55
giturl = https://github.com/Julian/jsonschema/
66
domain =

pypi-jsonschema.spec

+10-10
Original file line numberDiff line numberDiff line change
@@ -3,10 +3,10 @@
33
# Generated by: autospec.py
44
#
55
Name : pypi-jsonschema
6-
Version : 4.16.0
7-
Release : 91
8-
URL : https://files.pythonhosted.org/packages/cf/54/8923ba38b5145f2359d57e5516715392491d674c83f446cd4cd133eeb4d6/jsonschema-4.16.0.tar.gz
9-
Source0 : https://files.pythonhosted.org/packages/cf/54/8923ba38b5145f2359d57e5516715392491d674c83f446cd4cd133eeb4d6/jsonschema-4.16.0.tar.gz
6+
Version : 4.17.3
7+
Release : 92
8+
URL : https://files.pythonhosted.org/packages/36/3d/ca032d5ac064dff543aa13c984737795ac81abc9fb130cd2fcff17cfabc7/jsonschema-4.17.3.tar.gz
9+
Source0 : https://files.pythonhosted.org/packages/36/3d/ca032d5ac064dff543aa13c984737795ac81abc9fb130cd2fcff17cfabc7/jsonschema-4.17.3.tar.gz
1010
Summary : An implementation of JSON Schema validation for Python
1111
Group : Development/Tools
1212
License : MIT
@@ -66,18 +66,18 @@ python3 components for the pypi-jsonschema package.
6666

6767

6868
%prep
69-
%setup -q -n jsonschema-4.16.0
70-
cd %{_builddir}/jsonschema-4.16.0
69+
%setup -q -n jsonschema-4.17.3
70+
cd %{_builddir}/jsonschema-4.17.3
7171
pushd ..
72-
cp -a jsonschema-4.16.0 buildavx2
72+
cp -a jsonschema-4.17.3 buildavx2
7373
popd
7474

7575
%build
7676
export http_proxy=http://127.0.0.1:9/
7777
export https_proxy=http://127.0.0.1:9/
7878
export no_proxy=localhost,127.0.0.1,0.0.0.0
7979
export LANG=C.UTF-8
80-
export SOURCE_DATE_EPOCH=1666740963
80+
export SOURCE_DATE_EPOCH=1672164216
8181
export GCC_IGNORE_WERROR=1
8282
export AR=gcc-ar
8383
export RANLIB=gcc-ranlib
@@ -109,8 +109,8 @@ pytest || :
109109
export MAKEFLAGS=%{?_smp_mflags}
110110
rm -rf %{buildroot}
111111
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-jsonschema
112-
cp %{_builddir}/jsonschema-%{version}/COPYING %{buildroot}/usr/share/package-licenses/pypi-jsonschema/2de1a0a3674903238a664ace5d3acc66a7d546c7 || :
113-
cp %{_builddir}/jsonschema-%{version}/json/LICENSE %{buildroot}/usr/share/package-licenses/pypi-jsonschema/6808b97edf6d2c189571af702b95916168ff7db8 || :
112+
cp %{_builddir}/jsonschema-%{version}/COPYING %{buildroot}/usr/share/package-licenses/pypi-jsonschema/2de1a0a3674903238a664ace5d3acc66a7d546c7
113+
cp %{_builddir}/jsonschema-%{version}/json/LICENSE %{buildroot}/usr/share/package-licenses/pypi-jsonschema/6808b97edf6d2c189571af702b95916168ff7db8
114114
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
115115
echo ----[ mark ]----
116116
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
91
1+
92

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
912d562c1394408dca582e14843e3245df2f3827/jsonschema-4.16.0.tar.gz
1+
9f762c6c2b92defddf1c441cce8132d021252b2c/jsonschema-4.17.3.tar.gz

versions

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
4.16.0
1+
4.17.3

0 commit comments

Comments
 (0)