Skip to content

Commit 3a945d8

Browse files
committed
pypi-pre_commit: Autospec creation for update from version 2.16.0 to version 2.17.0
Anthony Sottile (11): add setuptools to the zipapp. resolves #2122 minor py2 cleanup for sys.stderr.buffer replace echo image with focal run dead, remove dead code work around python/mypy#11852 forbid overriding `entry` for meta hooks always use #!/bin/sh on windows Revert "work around python/mypy#11852" add git version to error output get lua version from luarocks itself v2.17.0 Jamie Alessio (1): Update rbenv / ruby-build versions Lorenz Walthert (3): better r path detection unset renv project no docs Matt Layman (1): Add naive and untested version of Lua language support. Ralf Schmitt (1): Use 'go install' instead of 'go get' Tony Rintala (2): fix: Add missing warning for regular expression with [\\/] fix: regex lists to regex tuples Uwe L. Korn (1): Add mamba support to `language: conda` pre-commit-ci[bot] (4): [pre-commit.ci] pre-commit autoupdate [pre-commit.ci] pre-commit autoupdate [pre-commit.ci] pre-commit autoupdate [pre-commit.ci] pre-commit autoupdate
1 parent e2f5a3b commit 3a945d8

File tree

7 files changed

+14
-17
lines changed

7 files changed

+14
-17
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-pre_commit
2-
URL = https://files.pythonhosted.org/packages/8e/e2/a5c93bd312072003117408cf87e2cb7dcf4992d28ce3cab9bc5eeabecf43/pre_commit-2.16.0.tar.gz
2+
URL = https://files.pythonhosted.org/packages/32/ea/13bb25c70e6d04b5788c42e0d3fcc82b06bc89f5d44c3c5606ef1af5a7cc/pre_commit-2.17.0.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

buildreq_cache

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,4 +1,4 @@
1-
2.16.0
1+
2.17.0
22
pypi(cfgv)
33
pypi(identify)
44
pypi(nodeenv)

options.conf

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-pre_commit
3-
url = https://files.pythonhosted.org/packages/8e/e2/a5c93bd312072003117408cf87e2cb7dcf4992d28ce3cab9bc5eeabecf43/pre_commit-2.16.0.tar.gz
3+
url = https://files.pythonhosted.org/packages/32/ea/13bb25c70e6d04b5788c42e0d3fcc82b06bc89f5d44c3c5606ef1af5a7cc/pre_commit-2.17.0.tar.gz
44
archives =
55
giturl = https://github.com/pre-commit/pre-commit
66
domain =

pypi-pre_commit.spec

+8-11
Original file line numberDiff line numberDiff line change
@@ -3,10 +3,10 @@
33
# Generated by: autospec.py
44
#
55
Name : pypi-pre_commit
6-
Version : 2.16.0
7-
Release : 13
8-
URL : https://files.pythonhosted.org/packages/8e/e2/a5c93bd312072003117408cf87e2cb7dcf4992d28ce3cab9bc5eeabecf43/pre_commit-2.16.0.tar.gz
9-
Source0 : https://files.pythonhosted.org/packages/8e/e2/a5c93bd312072003117408cf87e2cb7dcf4992d28ce3cab9bc5eeabecf43/pre_commit-2.16.0.tar.gz
6+
Version : 2.17.0
7+
Release : 14
8+
URL : https://files.pythonhosted.org/packages/32/ea/13bb25c70e6d04b5788c42e0d3fcc82b06bc89f5d44c3c5606ef1af5a7cc/pre_commit-2.17.0.tar.gz
9+
Source0 : https://files.pythonhosted.org/packages/32/ea/13bb25c70e6d04b5788c42e0d3fcc82b06bc89f5d44c3c5606ef1af5a7cc/pre_commit-2.17.0.tar.gz
1010
Summary : A framework for managing and maintaining multi-language pre-commit hooks.
1111
Group : Development/Tools
1212
License : MIT
@@ -15,9 +15,6 @@ Requires: pypi-pre_commit-license = %{version}-%{release}
1515
Requires: pypi-pre_commit-python = %{version}-%{release}
1616
Requires: pypi-pre_commit-python3 = %{version}-%{release}
1717
BuildRequires : buildreq-distutils3
18-
Provides: pre_commit
19-
Provides: pre_commit-python
20-
Provides: pre_commit-python3
2118
BuildRequires : buildreq-golang
2219
BuildRequires : pypi(cfgv)
2320
BuildRequires : pypi(identify)
@@ -74,15 +71,15 @@ python3 components for the pypi-pre_commit package.
7471

7572

7673
%prep
77-
%setup -q -n pre_commit-2.16.0
78-
cd %{_builddir}/pre_commit-2.16.0
74+
%setup -q -n pre_commit-2.17.0
75+
cd %{_builddir}/pre_commit-2.17.0
7976

8077
%build
8178
export http_proxy=http://127.0.0.1:9/
8279
export https_proxy=http://127.0.0.1:9/
8380
export no_proxy=localhost,127.0.0.1,0.0.0.0
8481
export LANG=C.UTF-8
85-
export SOURCE_DATE_EPOCH=1641471210
82+
export SOURCE_DATE_EPOCH=1642607531
8683
export GCC_IGNORE_WERROR=1
8784
export AR=gcc-ar
8885
export RANLIB=gcc-ranlib
@@ -98,7 +95,7 @@ python3 setup.py build
9895
export MAKEFLAGS=%{?_smp_mflags}
9996
rm -rf %{buildroot}
10097
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-pre_commit
101-
cp %{_builddir}/pre_commit-2.16.0/LICENSE %{buildroot}/usr/share/package-licenses/pypi-pre_commit/0a1b7c6ad0735b8a94231652bab67240e4b834f6
98+
cp %{_builddir}/pre_commit-2.17.0/LICENSE %{buildroot}/usr/share/package-licenses/pypi-pre_commit/0a1b7c6ad0735b8a94231652bab67240e4b834f6
10299
python3 -tt setup.py build install --root=%{buildroot}
103100
echo ----[ mark ]----
104101
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
13
1+
14

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
79c74fb4a634e5e84ee3f3e000ad674702139562/pre_commit-2.16.0.tar.gz
1+
a18c63bd8990a80fa4299575aa24db578ec0b7f8/pre_commit-2.17.0.tar.gz

versions

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
2.16.0
1+
2.17.0

0 commit comments

Comments
 (0)