Skip to content

Commit

Permalink
Add cfssl (#17)
Browse files Browse the repository at this point in the history
* add cfssl

* Install from docker
  • Loading branch information
osterman authored Jun 27, 2018
1 parent 50c4d40 commit 62663d3
Show file tree
Hide file tree
Showing 2 changed files with 15 additions and 0 deletions.
8 changes: 8 additions & 0 deletions Dockerfile
Original file line number Diff line number Diff line change
@@ -1,8 +1,16 @@
# Install CFSSL from official cfssl.org binaries
ARG CFSSL_VERSION=1.3.2
FROM cfssl/cfssl:${CFSSL_VERSION} as cfssl

# Install remaining packages
FROM alpine:3.7
ENV INSTALL_PATH=/packages/bin
ENV PATH=${INSTALL_PATH}:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
RUN mkdir -p ${INSTALL_PATH}
RUN apk add --update --no-cache make curl coreutils libc6-compat

COPY --from=cfssl /go/bin/ ${INSTALL_PATH}/

ADD . /packages
RUN make -C /packages/install/ all
WORKDIR /opt
7 changes: 7 additions & 0 deletions install/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -10,6 +10,7 @@ github_download_binary_release = $(CURL) -o $(INSTALL_PATH)/$@ https://github.co

all: awless \
aws-vault \
cfssl \
chamber \
fetch \
github-commenter \
Expand All @@ -18,6 +19,7 @@ all: awless \
helm \
helmfile \
htmltest \
hugo \
kops \
kubectl \
kubectx \
Expand All @@ -43,6 +45,11 @@ export AWS_VAULT_VERSION ?= 4.2.0
aws-vault:
$(call github_download_binary_release,99designs,v$(AWS_VAULT_VERSION),$@-$(OS)-$(ARCH))

export CFSSL_VERSION ?= 1.3.2
## Install cfssl - Cloudflare's PKI and TLS toolkit
cfssl:
@echo "The '$@' package is only availble in cloudposse/packages docker image"

export CHAMBER_VERSION ?= 2.0.0
## Install Chamber to manage secrets with SSM+KMS
chamber:
Expand Down

0 comments on commit 62663d3

Please sign in to comment.