Skip to content

Commit

Permalink
kde-frameworks/*: switch to xdg.eclass as ecm no longer provides it
Browse files Browse the repository at this point in the history
In Frameworks packages, KFMIN is derived from PV, which means for >=6.9.0,
pkg_postinst and pkg_postrm phase functions are no longer exported.

Amends a0ef7f4

Signed-off-by: Alfred Wingate <[email protected]>
Closes: #1027
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
parona-source authored and a17r committed Feb 2, 2025
1 parent ac0b6a3 commit 0cacee1
Show file tree
Hide file tree
Showing 3 changed files with 7 additions and 32 deletions.
14 changes: 2 additions & 12 deletions kde-frameworks/kcoreaddons/kcoreaddons-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,11 +1,11 @@
# Copyright 1999-2024 Gentoo Authors
# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

ECM_PYTHON_BINDINGS="off"
QTMIN=6.7.2
inherit ecm frameworks.kde.org xdg-utils
inherit ecm frameworks.kde.org xdg

DESCRIPTION="Framework for solving common problems such as caching, randomisation, and more"

Expand Down Expand Up @@ -48,13 +48,3 @@ src_test() {
# bug 619656
ecm_src_test -j1
}

pkg_postinst() {
ecm_pkg_postinst
xdg_mimeinfo_database_update
}

pkg_postrm() {
ecm_pkg_postrm
xdg_mimeinfo_database_update
}
14 changes: 2 additions & 12 deletions kde-frameworks/kio/kio-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2024 Gentoo Authors
# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand All @@ -8,7 +8,7 @@ ECM_HANDBOOK="optional"
ECM_HANDBOOK_DIR="docs"
ECM_TEST="forceoptional"
QTMIN=6.7.2
inherit ecm frameworks.kde.org xdg-utils
inherit ecm frameworks.kde.org xdg

DESCRIPTION="Framework providing transparent file and data management"

Expand Down Expand Up @@ -83,13 +83,3 @@ src_configure() {

ecm_src_configure
}

pkg_postinst() {
ecm_pkg_postinst
xdg_desktop_database_update
}

pkg_postrm() {
ecm_pkg_postrm
xdg_desktop_database_update
}
11 changes: 3 additions & 8 deletions kde-frameworks/purpose/purpose-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
# Copyright 1999-2024 Gentoo Authors
# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

ECM_QTHELP="false"
ECM_TEST="forceoptional"
QTMIN=6.7.2
inherit ecm frameworks.kde.org optfeature xdg-utils
inherit ecm frameworks.kde.org optfeature xdg

DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"

Expand Down Expand Up @@ -70,10 +70,5 @@ pkg_postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
optfeature "Send through KDE Connect" kde-misc/kdeconnect
fi
ecm_pkg_postinst
xdg_icon_cache_update
}

pkg_postrm() {
xdg_icon_cache_update
xdg_pkg_postinst
}

0 comments on commit 0cacee1

Please sign in to comment.