-
Notifications
You must be signed in to change notification settings - Fork 123
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Bring in latest udev version. Signed-off-by: Dmitry Sharshakov <[email protected]>
- Loading branch information
Showing
27 changed files
with
883 additions
and
505 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
31 changes: 31 additions & 0 deletions
31
systemd-udevd/patches/0001-Do-not-create-var-log-README.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,31 @@ | ||
From 425ad51e727058b48dd4580fd6afe7e51e96a28a Mon Sep 17 00:00:00 2001 | ||
From: Peter Kjellerstedt <[email protected]> | ||
Date: Tue, 21 Jan 2025 05:02:00 +0100 | ||
Subject: [PATCH] Do not create /var/log/README | ||
|
||
/var/log/README is a link to /usr/share/doc/systemd/README.logs. The | ||
latter is packaged in systemd-doc and likely not installed, which leaves | ||
/var/log/README as a dead link. Since /var/log/README is not very | ||
useful, just remove it. | ||
|
||
Upstream-Status: Inappropriate [OE specific] | ||
Signed-off-by: Peter Kjellerstedt <[email protected]> | ||
--- | ||
tmpfiles.d/legacy.conf.in | 3 --- | ||
1 file changed, 3 deletions(-) | ||
|
||
diff --git a/tmpfiles.d/legacy.conf.in b/tmpfiles.d/legacy.conf.in | ||
index b475500e58..650c91a8da 100644 | ||
--- a/tmpfiles.d/legacy.conf.in | ||
+++ b/tmpfiles.d/legacy.conf.in | ||
@@ -13,9 +13,6 @@ | ||
|
||
d /run/lock 0755 root root - | ||
L /var/lock - - - - ../run/lock | ||
-{% if CREATE_LOG_DIRS %} | ||
-L$ /var/log/README - - - - ../..{{DOC_DIR}}/README.logs | ||
-{% endif %} | ||
|
||
{% if HAVE_SYSV_COMPAT %} | ||
# /run/lock/subsys is used for serializing SysV service execution, and | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,6 +1,6 @@ | ||
From bc049f17be6eca828cc84861877d26092fea71a1 Mon Sep 17 00:00:00 2001 | ||
From 2c02b4a6f5b56f5b6a078c4b0fd0bbaab41f3d55 Mon Sep 17 00:00:00 2001 | ||
From: Dmitry Sharshakov <[email protected]> | ||
Date: Sat, 28 Sep 2024 19:09:54 +0200 | ||
Date: Thu, 30 Jan 2025 19:52:11 +0100 | ||
Subject: [PATCH] chore: musl headers compatibility for udev | ||
|
||
Signed-off-by: Dmitry Sharshakov <[email protected]> | ||
|
@@ -12,10 +12,10 @@ Signed-off-by: Dmitry Sharshakov <[email protected]> | |
4 files changed, 10 insertions(+), 6 deletions(-) | ||
|
||
diff --git a/src/basic/linux/if.h b/src/basic/linux/if.h | ||
index e79f5c8ceb..7a885ea299 100644 | ||
index b287b2a0bb..2639e69b52 100644 | ||
--- a/src/basic/linux/if.h | ||
+++ b/src/basic/linux/if.h | ||
@@ -130,10 +130,10 @@ enum net_device_flags { | ||
@@ -129,10 +129,10 @@ enum net_device_flags { | ||
#define IFF_LOWER_UP IFF_LOWER_UP | ||
#define IFF_DORMANT IFF_DORMANT | ||
#define IFF_ECHO IFF_ECHO | ||
|
@@ -28,7 +28,7 @@ index e79f5c8ceb..7a885ea299 100644 | |
#define IF_GET_IFACE 0x0001 /* for querying only */ | ||
#define IF_GET_PROTO 0x0002 | ||
diff --git a/src/basic/linux/if_ether.h b/src/basic/linux/if_ether.h | ||
index 69e0457eb2..4bf6341acf 100644 | ||
index a1aff8e337..847532aea0 100644 | ||
--- a/src/basic/linux/if_ether.h | ||
+++ b/src/basic/linux/if_ether.h | ||
@@ -166,7 +166,7 @@ | ||
|
@@ -41,10 +41,10 @@ index 69e0457eb2..4bf6341acf 100644 | |
|
||
#if __UAPI_DEF_ETHHDR | ||
diff --git a/src/basic/linux/libc-compat.h b/src/basic/linux/libc-compat.h | ||
index 8254c937c9..3e06d3eabb 100644 | ||
index e25cd3f486..3bc1776e70 100644 | ||
--- a/src/basic/linux/libc-compat.h | ||
+++ b/src/basic/linux/libc-compat.h | ||
@@ -172,18 +172,22 @@ | ||
@@ -153,18 +153,22 @@ | ||
* unsupported C libraries a way to opt out of any kernel definition. */ | ||
#else /* !defined(__GLIBC__) */ | ||
|
||
|
@@ -71,7 +71,7 @@ index 8254c937c9..3e06d3eabb 100644 | |
/* Everything up to IFF_DYNAMIC, matches net/if.h until glibc 2.23 */ | ||
#ifndef __UAPI_DEF_IF_NET_DEVICE_FLAGS | ||
diff --git a/src/basic/linux/netdevice.h b/src/basic/linux/netdevice.h | ||
index f3770c5b0f..6125206f33 100644 | ||
index 86d961c911..97fce6fb17 100644 | ||
--- a/src/basic/linux/netdevice.h | ||
+++ b/src/basic/linux/netdevice.h | ||
@@ -31,7 +31,7 @@ | ||
|
@@ -84,5 +84,5 @@ index f3770c5b0f..6125206f33 100644 | |
|
||
/* Initial net device group. All devices belong to group 0 by default. */ | ||
-- | ||
2.46.1 | ||
2.48.1 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,7 +1,7 @@ | ||
From 34b7e1ed3b9a896db6fad435fd141c385c7337d1 Mon Sep 17 00:00:00 2001 | ||
From f99ef6c4407b56e8d15455fe27eb732ada87215b Mon Sep 17 00:00:00 2001 | ||
From: Chen Qi <[email protected]> | ||
Date: Mon, 25 Feb 2019 13:55:12 +0800 | ||
Subject: [PATCH 04/27] missing_type.h: add comparison_fn_t | ||
Subject: [PATCH 03/26] missing_type.h: add comparison_fn_t | ||
|
||
Make it work with musl where comparison_fn_t and is not provided. | ||
|
||
|
@@ -45,7 +45,7 @@ index 9c818bd747..ef10c8be2c 100644 | |
/* This is the same as glibc's internal __compar_d_fn_t type. glibc exports a public comparison_fn_t, for the | ||
* external type __compar_fn_t, but doesn't do anything similar for __compar_d_fn_t. Let's hence do that | ||
diff --git a/src/libsystemd/sd-journal/catalog.c b/src/libsystemd/sd-journal/catalog.c | ||
index a0b673f65f..29dd2fee16 100644 | ||
index 7dcc35d8d5..87b8d6aad6 100644 | ||
--- a/src/libsystemd/sd-journal/catalog.c | ||
+++ b/src/libsystemd/sd-journal/catalog.c | ||
@@ -29,6 +29,7 @@ | ||
|
@@ -57,4 +57,5 @@ index a0b673f65f..29dd2fee16 100644 | |
const char * const catalog_file_dirs[] = { | ||
"/usr/local/lib/systemd/catalog/", | ||
-- | ||
2.45.1 | ||
2.34.1 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,7 +1,7 @@ | ||
From 4a4005583e2debe491850229aa5ae2a97770532d Mon Sep 17 00:00:00 2001 | ||
From 34fe809cf686c1a81db5f3f027e33fece350ba0b Mon Sep 17 00:00:00 2001 | ||
From: Alexander Kanavin <[email protected]> | ||
Date: Sat, 22 May 2021 20:26:24 +0200 | ||
Subject: [PATCH 05/27] add fallback parse_printf_format implementation | ||
Subject: [PATCH 04/26] add fallback parse_printf_format implementation | ||
|
||
Upstream-Status: Inappropriate [musl specific] | ||
|
||
|
@@ -22,22 +22,22 @@ Signed-off-by: Scott Murray <[email protected]> | |
create mode 100644 src/basic/parse-printf-format.h | ||
|
||
diff --git a/meson.build b/meson.build | ||
index 52723bef09..e20bf3af8a 100644 | ||
index bffda86845..4146f4beef 100644 | ||
--- a/meson.build | ||
+++ b/meson.build | ||
@@ -753,6 +753,7 @@ foreach header : ['crypt.h', | ||
@@ -773,6 +773,7 @@ foreach header : ['crypt.h', | ||
'linux/ioprio.h', | ||
'linux/memfd.h', | ||
'linux/time_types.h', | ||
'linux/vm_sockets.h', | ||
+ 'printf.h', | ||
'sys/auxv.h', | ||
'sys/sdt.h', | ||
'threads.h', | ||
diff --git a/src/basic/meson.build b/src/basic/meson.build | ||
index 9a214575a5..b49b6ade56 100644 | ||
index e02f787c75..9435df895d 100644 | ||
--- a/src/basic/meson.build | ||
+++ b/src/basic/meson.build | ||
@@ -189,6 +189,11 @@ endforeach | ||
@@ -188,6 +188,11 @@ endforeach | ||
|
||
basic_sources += generated_gperf_headers | ||
|
||
|
@@ -430,4 +430,5 @@ index 7d02b57d7b..75e8e08add 100644 | |
#define SNDBUF_SIZE (8*1024*1024) | ||
|
||
-- | ||
2.45.1 | ||
2.34.1 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,7 +1,7 @@ | ||
From ed836c3478e1193e99e37d50db96d124796a3322 Mon Sep 17 00:00:00 2001 | ||
From d368a0317c747961f69a455a09a3de3fd13410a2 Mon Sep 17 00:00:00 2001 | ||
From: Chen Qi <[email protected]> | ||
Date: Mon, 25 Feb 2019 14:56:21 +0800 | ||
Subject: [PATCH 06/27] don't fail if GLOB_BRACE and GLOB_ALTDIRFUNC is not | ||
Subject: [PATCH 05/26] don't fail if GLOB_BRACE and GLOB_ALTDIRFUNC is not | ||
defined | ||
|
||
If the standard library doesn't provide brace | ||
|
@@ -115,7 +115,7 @@ index 49d71f15c7..0a49ebcc17 100644 | |
|
||
(void) rm_rf(template, REMOVE_ROOT|REMOVE_PHYSICAL); | ||
diff --git a/src/tmpfiles/tmpfiles.c b/src/tmpfiles/tmpfiles.c | ||
index 807925f199..b4f86fc611 100644 | ||
index 86bf16356d..da552dbaab 100644 | ||
--- a/src/tmpfiles/tmpfiles.c | ||
+++ b/src/tmpfiles/tmpfiles.c | ||
@@ -73,6 +73,12 @@ | ||
|
@@ -131,7 +131,7 @@ index 807925f199..b4f86fc611 100644 | |
/* This reads all files listed in /etc/tmpfiles.d/?*.conf and creates | ||
* them in the file system. This is intended to be used to create | ||
* properly owned directories beneath /tmp, /var/tmp, /run, which are | ||
@@ -2570,7 +2576,9 @@ finish: | ||
@@ -2573,7 +2579,9 @@ finish: | ||
|
||
static int glob_item(Context *c, Item *i, action_t action) { | ||
_cleanup_globfree_ glob_t g = { | ||
|
@@ -141,7 +141,7 @@ index 807925f199..b4f86fc611 100644 | |
}; | ||
int r; | ||
|
||
@@ -2598,7 +2606,9 @@ static int glob_item_recursively( | ||
@@ -2601,7 +2609,9 @@ static int glob_item_recursively( | ||
fdaction_t action) { | ||
|
||
_cleanup_globfree_ glob_t g = { | ||
|
@@ -152,4 +152,5 @@ index 807925f199..b4f86fc611 100644 | |
int r; | ||
|
||
-- | ||
2.45.1 | ||
2.34.1 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,7 +1,7 @@ | ||
From 41abe1a4136babfe5df63e9561dcf29d3c8fe6e9 Mon Sep 17 00:00:00 2001 | ||
From 85d8c4c27e855d54c1740902a836c8f2aea9bebc Mon Sep 17 00:00:00 2001 | ||
From: Chen Qi <[email protected]> | ||
Date: Mon, 25 Feb 2019 15:12:41 +0800 | ||
Subject: [PATCH 08/27] Use uintmax_t for handling rlim_t | ||
Subject: [PATCH 07/26] Use uintmax_t for handling rlim_t | ||
|
||
PRIu{32,64} is not right format to represent rlim_t type | ||
therefore use %ju and typecast the rlim_t variables to | ||
|
@@ -27,10 +27,10 @@ Signed-off-by: Chen Qi <[email protected]> | |
3 files changed, 9 insertions(+), 15 deletions(-) | ||
|
||
diff --git a/src/basic/format-util.h b/src/basic/format-util.h | ||
index ba7cff6a8b..2736abb07b 100644 | ||
index b528c005ca..41c4c095be 100644 | ||
--- a/src/basic/format-util.h | ||
+++ b/src/basic/format-util.h | ||
@@ -42,13 +42,7 @@ assert_cc(sizeof(gid_t) == sizeof(uint32_t)); | ||
@@ -41,13 +41,7 @@ assert_cc(sizeof(gid_t) == sizeof(uint32_t)); | ||
# error Unknown timex member size | ||
#endif | ||
|
||
|
@@ -86,10 +86,10 @@ index a9f7b87f28..059c67731d 100644 | |
return 1; | ||
} | ||
diff --git a/src/core/execute.c b/src/core/execute.c | ||
index 513e95e09d..0e269617f8 100644 | ||
index 3d55b0b772..4824ff159e 100644 | ||
--- a/src/core/execute.c | ||
+++ b/src/core/execute.c | ||
@@ -1067,9 +1067,9 @@ void exec_context_dump(const ExecContext *c, FILE* f, const char *prefix) { | ||
@@ -1162,9 +1162,9 @@ void exec_context_dump(const ExecContext *c, FILE* f, const char *prefix) { | ||
for (unsigned i = 0; i < RLIM_NLIMITS; i++) | ||
if (c->rlimit[i]) { | ||
fprintf(f, "%sLimit%s: " RLIM_FMT "\n", | ||
|
@@ -102,4 +102,5 @@ index 513e95e09d..0e269617f8 100644 | |
|
||
if (c->ioprio_set) { | ||
-- | ||
2.45.1 | ||
2.34.1 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,7 +1,7 @@ | ||
From ea8e85d92f67a7af8577a4ce7c67c7aaee65d10c Mon Sep 17 00:00:00 2001 | ||
From f4cd939c7cc1ce0a59bab2693768f2c95d9ced00 Mon Sep 17 00:00:00 2001 | ||
From: Khem Raj <[email protected]> | ||
Date: Sun, 27 May 2018 08:36:44 -0700 | ||
Subject: [PATCH 10/27] Define glibc compatible basename() for non-glibc | ||
Subject: [PATCH 08/26] Define glibc compatible basename() for non-glibc | ||
systems | ||
|
||
Fixes builds with musl, even though systemd is adamant about | ||
|
@@ -15,10 +15,10 @@ Signed-off-by: Khem Raj <[email protected]> | |
1 file changed, 4 insertions(+) | ||
|
||
diff --git a/src/basic/string-util.h b/src/basic/string-util.h | ||
index ff5efbcf55..d1a6bb0e76 100644 | ||
index cc6aa183c0..0b035125cd 100644 | ||
--- a/src/basic/string-util.h | ||
+++ b/src/basic/string-util.h | ||
@@ -26,6 +26,10 @@ | ||
@@ -27,6 +27,10 @@ | ||
#define URI_UNRESERVED ALPHANUMERICAL "-._~" /* [RFC3986] */ | ||
#define URI_VALID URI_RESERVED URI_UNRESERVED /* [RFC3986] */ | ||
|
||
|
@@ -30,4 +30,5 @@ index ff5efbcf55..d1a6bb0e76 100644 | |
if (!haystack || !needle) | ||
return NULL; | ||
-- | ||
2.45.1 | ||
2.34.1 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,7 +1,7 @@ | ||
From 7c8634c441401b034cd4bcf4b916a7042076fca8 Mon Sep 17 00:00:00 2001 | ||
From 6959db351fdd551d46e22667deec6032552b2662 Mon Sep 17 00:00:00 2001 | ||
From: Chen Qi <[email protected]> | ||
Date: Wed, 4 Jul 2018 15:00:44 +0800 | ||
Subject: [PATCH 11/27] Do not disable buffering when writing to oom_score_adj | ||
Subject: [PATCH 09/26] Do not disable buffering when writing to oom_score_adj | ||
|
||
On musl, disabling buffering when writing to oom_score_adj will | ||
cause the following error. | ||
|
@@ -24,10 +24,10 @@ Signed-off-by: Scott Murray <[email protected]> | |
1 file changed, 1 insertion(+), 1 deletion(-) | ||
|
||
diff --git a/src/basic/process-util.c b/src/basic/process-util.c | ||
index c9d968dee0..7d6d3ce7db 100644 | ||
index 3253a9c3fb..772c4082a1 100644 | ||
--- a/src/basic/process-util.c | ||
+++ b/src/basic/process-util.c | ||
@@ -1816,7 +1816,7 @@ int set_oom_score_adjust(int value) { | ||
@@ -1848,7 +1848,7 @@ int set_oom_score_adjust(int value) { | ||
xsprintf(t, "%i", value); | ||
|
||
return write_string_file("/proc/self/oom_score_adj", t, | ||
|
@@ -37,4 +37,5 @@ index c9d968dee0..7d6d3ce7db 100644 | |
|
||
int get_oom_score_adjust(int *ret) { | ||
-- | ||
2.45.1 | ||
2.34.1 | ||
|
Oops, something went wrong.